Ask Your Question
0

Unable to install openstack [ERROR : Failed to run remote script]

asked 2017-08-01 10:06:46 -0600

ankit355 gravatar image

I have installed Centos 7 in virtual box. Proxy sits between the (host and guest OS) to connect to internet. I am able to access Internet from the guest machine,, and all commands through command line like "yum", is also working. But when I install packstack and run "Packstack --allinone" command, I ended up getting the following error.

Any help will be much appreciated.

[root@centos ~]# packstack --allinone Welcome to the Packstack setup utility

The installation log file is available at: /var/tmp/packstack/20170801-103422-utRTM4/openstack-setup.log

Installing: Clean Up [ DONE ] Discovering ip protocol version [ DONE ] Setting up ssh keys [ DONE ] Preparing servers [ DONE ] Pre installing Puppet and discovering hosts' details[ ERROR ]

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror, langpacks Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock (http://mirrorlist.centos.org/?release...) error was 14: curl#7 - "Failed to connect to 2001:4178:5:200::10: Network is unreachable"

stderr: Warning: Permanently added '10.0.2.15' (ECDSA) to the list of known hosts. + trap t ERR + yum install -y puppet hiera openssh-clients tar nc rubygem-json

One of the configured repositories failed (Unknown), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64 ++ t ++ exit 1

Please check log file /var/tmp/packstack/20170801-103422-utRTM4/openstack-setup.log for more information Additional information: * A new answerfile was created in: /root/packstack-answers-20170801-103423.txt * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components. [root@centos ~]#

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-08-03 05:41:04 -0600

Shaik Saddam Hussain gravatar image

I was able to resolve it by making sure proper repo is configured with good internet connectivity

edit flag offensive delete link more
0

answered 2017-08-02 04:51:40 -0600

ankit355 gravatar image

I was able to resolve it by adding proxy details to yum.conf file. Proxy=http://ipaddress:portnum

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-08-01 10:06:46 -0600

Seen: 153 times

Last updated: Aug 03