how to configure gnocchi in ocata on centos 7

asked 2017-07-27 12:43:46 -0500

juscloud gravatar image

im working on single node on centos 7 but not getting how to setup gnocchi configuration n im follwoing openstack offical docs but that docs is little bit confusing as they didnt properly mentioned gnochhi installation package n configuration .....but i tried to install gnocchi by using yum install openstack-gnocchi but after installing gnocchi im not getting keystone_authtoken section so i manually added keystone_authtoken section i think it wont work cuz im getting .......Unable to establish connection to http://localhost:8041/v1/resource/image (http://localhost:8041/v1/resource/image?): HTTPConnectionPool(host='localhost', port=8041): Max retries exceeded with url: /v1/resource/image (Caused by NewConnectionError('<requests.packages.urllib3.connection.httpconnection 0x3528c10="" at="" object="">: Failed to establish a new connection: [Errno 111] Connection refused',)) erro finally ...pls help me with above issue...</requests.packages.urllib3.connection.httpconnection>

edit retag flag offensive close merge delete

Comments

What do you do to get this error message, and where does it appear?

localhost looks wrong; find the place where you configured it and replace it with the IP address or the hostname of the server.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-28 22:36:15 -0500 )edit

By the way, Red Hat has instructions on installing and configuring Gnocchi for their OpenStack product: https://access.redhat.com/documentati...

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-28 22:42:13 -0500 )edit