Load Balancer only uses default SG

asked 2017-07-26 10:21:56 -0500

MatthewSecaur gravatar image

Hello,

I have created a load balancer and two servers using Heat. In my Packstack environment, this works fine, including the creation of a SG for the stack. However, in my DIY OS environment, the LB only uses rules in the Default SG, not the SG that is created by Heat.

In other words, the two instances start up on the private network and are listening on port 80. The Load Balancer has a floating IP in the public network, but I get a timeout when I try to connect to the LB on the floating IP. If I then add port 80 to the Default SG (port 80 is already in the SG created by the Heat stack), then the LB works just as it should. The LB should already work, though, since the SG created by the stack already includes port 80. The LB is being created in the same stack.

I feel there is something wrong here and I would like some help understanding what's going wrong.

Thank you!

P.S. I am not including the Heat configuration because I get the same behavior even if I build all the components by hand.

edit retag flag offensive close merge delete