Linux bridge agent on compute node

asked 2017-07-26 03:07:12 -0600

anonymous user

Anonymous

Hi, I set up OpenStack Ocata on CentOS 7. When I run openstack network agent list on the controller node, I get this:

+--------------------------------------+--------------------+----------------+-------------------+-------+-------+---------------------------+
| ID                                   | Agent Type         | Host           | Availability Zone | Alive | State | Binary                    |
+--------------------------------------+--------------------+----------------+-------------------+-------+-------+---------------------------+
| 00c3d27c-80cf-4000-b09d-16e6be306d1e | Linux bridge agent | controller0101 | None              | True  | UP    | neutron-linuxbridge-agent |
| 4414a2c6-704e-47d4-9c3e-bb9bf3f3c866 | Metadata agent     | controller0101 | None              | True  | UP    | neutron-metadata-agent    |
| 507b1246-9586-46a4-b17a-a5d080b9f521 | DHCP agent         | controller0101 | nova              | True  | UP    | neutron-dhcp-agent        |
| b7d0a3f4-0eba-4e81-a106-21594b3d9b88 | L3 agent           | controller0101 | nova              | True  | UP    | neutron-l3-agent          |
+--------------------------------------+--------------------+----------------+-------------------+-------+-------+---------------------------+

Linux bridge agent from compute node missing in this list.

On compute node I checked linuxbridge-agent log (/var/log/neutron/linuxbridge-agent.log) and I noticed this:

2017-07-26 09:28:26.022 14961 INFO neutron.common.config [-] Logging enabled!
2017-07-26 09:28:26.023 14961 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 10.0.1
2017-07-26 09:28:26.023 14961 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {'provider': 'ens224'}
2017-07-26 09:28:26.023 14961 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2017-07-26 09:28:26.038 14961 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip CONTROLLER_IP on the host interface to be used for tunneling and restart the agent.

On the both nodes I have two interfaces, ens192 (private, management network) and ens224 (public network).

My linuxbridge_agent.ini on compute node (/etc/neutron/plugins/ml2/linuxbridge_agent.ini)

[linux_bridge]
physical_interface_mappings = provider:ens224

[vxlan]
enable_vxlan = true
local_ip = CONTROLLER_IP
l2_population = true

How can I fix the error? Should I set the public IP address instead controller IP address in local_ip variable (/etc/neutron/plugins/ml2/linuxbridge_agent.ini)?

Does enyone have any idea?

Thanks

edit retag flag offensive close merge delete

Comments

local_ip should be the ip address of the compute node. If, as in the tutorial guides, you are using the management network for tunnels then change to the COMPUTE node mgt. interface ip and restart the linuxbridge service on the compute node.

luowei gravatar imageluowei ( 2017-07-26 14:13:25 -0600 )edit

local_ip in /etc/neutron/plugins/ml2/linuxbridge_agent.ini must be the private ip address of your compute node. Restart linuxbridge service and verify.

Praveen N gravatar imagePraveen N ( 2017-07-27 01:20:32 -0600 )edit

Thanks to both of you.

I did this and it does not help. I still don't see the linux bridge service from compute node.

linuxbridge-agent.log

2017-07-27 11:37:16.251 12704 CRITICAL neutron [-] Exception: Failed to spawn rootwrap process.
cloudadmin gravatar imagecloudadmin ( 2017-07-27 05:35:08 -0600 )edit

Did you install openstack-selinux?

luowei gravatar imageluowei ( 2017-07-27 09:02:08 -0600 )edit