Ask Your Question
0

Invalid API version parameter. Supported values are [1, 2]

asked 2017-07-25 23:52:16 -0500

liaodalin19903 gravatar image

updated 2017-07-25 23:57:17 -0500

After I install the glance, When I execute the:

[root@ha-node1 ~]# glance image-create --name "cirros-0.3.4-x86_64" --file cirros-0.3.4-x86_64-disk.img --disk-format qcow2 --container-format bare --visibility public --progress

I get the below error:

Invalid API version parameter. Supported values are [1, 2]

And if I use the glance image-list will get this error too:

[root@ha-node1 ~]# glance image-list 
Invalid API version parameter. Supported values are [1, 2]

And in my /root/admin-openrc:

export OS_USER_DOMAIN_ID=default
export OS_PROJECT_DOMAIN_ID=default
export OS_USERNAME=admin
export OS_PROJECT_NAME=admin
export OS_PASSWORD=passw0rd
export OS_IDENTITY_API_VERSION=3
export OS_AUTH_URL=http://devops.taobao.com:35357/v3
export OS_IMAGE_API_VERSION=3

I set the OS_IMAGE_API_VERSION is 3, why I can not use the API version 3 parameter

Someone know why there is the error?

My OpenStack is Newton. VM is CentOS 7.2

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-07-27 02:32:13 -0500

liaodalin19903 gravatar image

At last I found the glance only support version 2 in newton, so I change to the : export OS_IMAGE_API_VERSION=2 in my /root/admin-openrc

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-25 23:52:16 -0500

Seen: 61 times

Last updated: Jul 27 '17