Ask Your Question
0

Kolla-ansible with vlan provider

asked 2017-07-24 08:36:50 -0600

Pedro_Pacheco gravatar image

I installed release Newton, via kolla-ansible with successful, using network provider as flat driver (Until here, everything is gone fine! ). But, i cannot do the same using network as VLAN provider. On file Global.yml, specifically in these arguments, i did set : neutron_interface: "bond0.3030" , and : neutron_external_interface: "bond0", i destroyed all (kolla-ansbile destroy --yes), and deploy again without problem, however, my instances doesn't ping for external world (alls containers are fine - started and with router iptables rules {SNAT} fine too).

Reading my ml2.conf.ini, i saw that argument is empty: network_vlan_ranges = (When did try make one external network, typing: --provider:physical_network physnet1 received output: "Invalid input for operation: physical_network 'physnet1' unknown for VLAN provider network.")

So, I did set here, the name of my physical_network and VLANID where i wish, staying like this:

physical_network names = physnet1:3030:3030

restart all services, i did put it again the command bellow without erros, but nothing works yet.

neutron net-create vlan3030 --shared --provider:network_type vlan --provider:segmentation_id 3030 --provider:physical_network physnet1 --router:external

kolla-ansible: 4.0.2; Openstack release: Newton (tag = 3.04); Operation System: Centos7-.21.1.el7.x86_64

edit retag flag offensive close merge delete

Comments

Hi Pedro, did you manage to create VLAN provider successfully? would you mind to share how did you configure your host interfaces and interfaces in globals.yml?

adrianreza gravatar imageadrianreza ( 2018-02-21 21:22:36 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2017-08-11 04:28:02 -0600

Paul Bourke gravatar image

You're close to correct - you need to override the network_vlan_ranges value in ml2_conf.ini using kolla-ansible's override mechanism.

Create a file called /etc/kolla/config/neutron/ml2_conf.ini on your deploy node and add something like the following to match your setup:

 [ml2_type_vlan]
  network_vlan_ranges = physnet1:1100:1110

Then redeploy.

For more info see:

https://wiki.openstack.org/wiki/Ml2_c...
https://docs.openstack.org/developer/...

edit flag offensive delete link more

Comments

Hi pbourke, how to achieve network like this in kolla-ansible? control + network node: eth0: management network, eth1: physnet1, tenant1 VLAN200, tenant2 VLAN300, eth2: physnet2, external net compute node: eth0: management network, eth1: physnet1, tenant1 VLAN200, tenant2 VLAN300

I need advice pls

adrianreza gravatar imageadrianreza ( 2018-02-21 21:27:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-24 08:35:35 -0600

Seen: 377 times

Last updated: Aug 11 '17