Ask Your Question
0

DevStack: Could not find a version that satisfies the requirement pbr===1.10.0

asked 2017-07-22 11:25:32 -0500

ge0rgi gravatar image

I have been using the stable/ocata branch of DevStack for the last couple of months without any problems. However when I tried to run stack.sh today I got this error;

Could not fetch URL https://pypi.python.org/simple/pbr/: There was a problem confirming the ssl certificate: [Errno 1] _ssl.c:510: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed - skipping
  Could not find a version that satisfies the requirement pbr===1.10.0 (from -c /opt/stack/requirements/upper-constraints.txt (line 262)) (from versions: )
No matching distribution found for pbr===1.10.0 (from -c /opt/stack/requirements/upper-constraints.txt (line 262))

When I try to install pbr I have using pip install pbr in fact pip say that pbr is already installed Requirement already satisfied: pbr===1.10.0 in /usr/local/lib/python2.7/dist-packages Howver DevStack attempts to install it again and fials. I also tried to uninstall pbrand install it again using pip. I got no SSL errors, the problem seems to occur only when running stack.sh

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-08-12 22:41:01 -0500

i met the same question and i just removed the line about pbr in opt/stack/requirements/upper-constraints.txt.The program goes on.

edit flag offensive delete link more

Comments

or you can change your pipy source.

doudoupo gravatar imagedoudoupo ( 2018-08-13 04:17:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-22 11:25:32 -0500

Seen: 787 times

Last updated: Jul 22 '17