devstack-newton with ceilometer - ContextualVersionConflict: (tooz 1.43.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('tooz[zake]>=1.47.0'), set(['ceilometer']))

asked 2017-07-20 15:01:46 -0600

Sireesh gravatar image

Hi,

I am trying to install devstack ( newton ) with ceilometer but getting below error:

2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main 2017-07-20 19:41:26.262 | status = self.run(options, args) 2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 335, in run 2017-07-20 19:41:26.262 | wb.build(autobuilding=True) 2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build 2017-07-20 19:41:26.262 | self.requirement_set.prepare_files(self.finder) 2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files 2017-07-20 19:41:26.262 | ignore_dependencies=self.ignore_dependencies)) 2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 521, in _prepare_file 2017-07-20 19:41:26.262 | req_to_install.check_if_exists() 2017-07-20 19:41:26.262 | File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1036, in check_if_exists 2017-07-20 19:41:26.263 | self.req.name 2017-07-20 19:41:26.263 | File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 558, in get_distribution 2017-07-20 19:41:26.263 | dist = get_provider(dist) 2017-07-20 19:41:26.263 | File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 432, in get_provider 2017-07-20 19:41:26.263 | return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0] 2017-07-20 19:41:26.263 | File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 968, in require 2017-07-20 19:41:26.263 | needed = self.resolve(parse_requirements(requirements)) 2017-07-20 19:41:26.263 | File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 859, in resolve 2017-07-20 19:41:26.263 | raise VersionConflict(dist, req).with_context(dependent_req) 2017-07-20 19:41:26.263 | ContextualVersionConflict: (tooz 1.43.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('tooz[zake]>=1.47.0'), set(['ceilometer']))**

I tried upgrading tooz but stack.sh still shows the same error , might be stack.sh is reinstalling tooz

stack@ubuntu:~/devstack$ sudo pip install tooz==1.58.0 Installing collected packages: tooz Found existing installation: tooz 1.43.1 Uninstalling tooz-1.43.1: Successfully uninstalled tooz-1.43.1 Successfully installed tooz-1.58.0

My local.conf:

[[local|localrc]]

ADMIN_PASSWORD=<my password=""> DATABASE_PASSWORD=stackdb RABBIT_PASSWORD=stackqueue SERVICE_PASSWORD=$ADMIN_PASSWORD SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5 SWIFT_REPLICAS=1 SWIFT_DATA_DIR=$DEST/data CEILOMETER_BACKEND=mongodb enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer (https://git.openstack.org/openstack/c...) enable_plugin aodh https://git.openstack.org/openstack/aodh</my>

I am struggling to bring devstack up with ceilometer

edit retag flag offensive close merge delete

Comments

any help would be appreciated or any other way to get devstack+ ceilometer running?

Sireesh gravatar imageSireesh ( 2017-07-21 10:53:21 -0600 )edit