Ask Your Question
0

cpu overcommit does not work

asked 2017-07-19 18:33:22 -0500

buggy gravatar image

I have set cpu_allocation_ratio=32.0 and enabled CoreFilter I understand I can only see the actual cores but not the overcomitted total cores. openstack hypervisor stats show +----------------------+--------+ | Field | Value | +----------------------+--------+ | count | 3 | | current_workload | 0 | | disk_available_least | 2347 | | free_disk_gb | 3752 | | free_ram_mb | 83938 | | local_gb | 5613 | | local_gb_used | 3246 | | memory_mb | 147426 | | memory_mb_used | 49786 | | running_vms | 7 | | vcpus | 40 | | vcpus_used | 33 | +----------------------+--------+

However when I try to launch a VM with 12 vCPU, it always gives error saying no valid host is found. I can only create VM with 8 vCPU or fewer.

Why CPU overcommit does not work?

Am I mssing something in config files?

I am using Ocata.

Any comments are welcome.

Many Thanks

edit retag flag offensive close merge delete

Comments

This is my scheduler-default-filters values

AvailabilityZoneFilter,CoreFilter,RamFilter,ComputeFilter,ComputeCapabilitiesFilter,ImagePropertiesFilter,ServerGroupAntiAffinityFilter,ServerGroupAffinityFilter

Try adding the missing ones and check

Deepa gravatar imageDeepa ( 2017-07-21 04:19:16 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-07-20 16:03:46 -0500

buggy gravatar image

Here is my nova.conf settings for the parameters mentioned: cpu_allocation_ratio=32.0

available_filters=nova.scheduler.filters.all_filters enabled_filters=RetryFilter,ComputeFilter,ImagePropertiesFilter,CoreFilter,SameHostFilter,ServerGroupAffinityFilter

And I also discovered another related problem. I tried to scale down one of the instance from 8 cpu to 4 cpu. And I got the same error: No valid host is found.

How can I determine what the nova conductor is complaining?

Many Thanks

edit flag offensive delete link more

Comments

I think you also need at least the AvailabilityZoneFilter.

luowei gravatar imageluowei ( 2017-07-20 19:58:14 -0500 )edit
0

answered 2017-07-20 02:24:17 -0500

Deepa gravatar image

I think you should set cpu_allocation_ratio = 16 or 32 in nova-cloud-controller machine ,under /etc/nova/nova.conf file .

edit flag offensive delete link more
0

answered 2017-07-19 20:39:49 -0500

luowei gravatar image

updated 2017-07-19 20:52:00 -0500

I think the filter names changed. Should have something in /etc/nova/nova.conf like:

[DEFAULT]
cpu_allocation_ratio=32.0

[filter_scheduler]
available_filters=nova.scheduler.filters.all_filters
enabled_filters=RetryFilter,AvailabilityZoneFilter,RamFilter,DiskFilter,ComputeFilter,ComputeCapabilitiesFilter,ImagePropertiesFilter,ServerGroupAntiAffinityFilter,ServerGroupAffinityFilter,SameHostFilter

btw, you can't just put the ComputeFilter. You need some of the others for it to work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-07-19 18:33:22 -0500

Seen: 301 times

Last updated: Jul 20 '17