Ask Your Question
1

403 Forbidden gnocchi api

asked 2017-07-18 05:04:22 -0600

viinay gravatar image

devstack branch : master(pike) Im trying to install telemetry services (panko,aodh,gnocchi) with devstack.the installation was successfull with these plugins enabled but when executing command : openstack metric list I get the following error.I tried to edit the auth_mode to basic (previously auth_mode:keystone ) in /etc/gnocchi/gnocchi.conf file but know success.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html>
    <head>
        <title>403 Forbidden</title>
    </head>
    <body>
        <h1>Forbidden</h1>
        <p>You don't have permission to access /v1/metric
on this server.
            <br />
        </p>
        <hr>
        <address>Apache/2.4.18 (Ubuntu) Server at 38.87.46.116 Port 8041</address>
    </body>
</html>

gnocchi.log file shows client denied by server configuration.Am I missing any configuration ?

edit retag flag offensive close merge delete

Comments

I'm facing the same issue, every gnocchi command returns a 403 error, though I configured /etc/gnocchi/gnocchi.conf with keystone_authtoken options, mentionned gnocchi in the meter_dispatchers and event_dispatchers options in /etc/ceilometer/ceilometer.conf, and sourced the openrc file.

Wintermute gravatar imageWintermute ( 2017-07-24 08:27:55 -0600 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2017-08-03 02:48:30 -0600

nakamura-h gravatar image

I was facing the same 403 error . By updating /etc/apache2/sites-enabled/gnocchi.conf and restart apache2, I was able to access gnocchi.

I inserted the following Directory directive before closing VirtualHost directive.

<Directory />
    Options FollowSymLinks
    AllowOverride None
    <IfVersion >= 2.4>
        Require all granted
    </IfVersion>
    <IfVersion < 2.4>
        Order allow,deny
        Allow from all
    </IfVersion>
</Directory>
edit flag offensive delete link more
0

answered 2017-08-02 22:12:51 -0600

kirito gravatar image

I am on devstack ocata

# gnocchi metric list
The request you have made requires authentication. (HTTP 401)

then i try noauth

# vim /etc/gnocchi/gnocchi.conf

[api]
auth_mode = noauth
#auth_mode = keystone

then use this env,the GNOCCHI_USER_ID、GNOCCHI_PROJECT_ID and GNOCCHI_ENDPOINT come from /etc/gnocchi/gnocchi.conf

export OS_AUTH_TYPE=gnocchi-noauth
export GNOCCHI_USER_ID=d3c5a671-30be-4f3f-892b-184464fcfdd0
export GNOCCHI_PROJECT_ID=4c718289-51d7-4f3e-b846-ec0875572459
export GNOCCHI_ENDPOINT=http://192.168.3.222:8041

It work,no error

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-18 05:04:22 -0600

Seen: 989 times

Last updated: Aug 03 '17