Ask Your Question
0

Unable to access instance

asked 2017-07-17 06:32:49 -0500

fayvaz gravatar image

I have an RHEL6.6 vdi image and converted it to QCOW2 by means of qemu-img.

With this image, I created an instance. However, I could not ssh this image.

Do you have any idea about this trouble?

Note: I have proper security group definitions.

Many thanks, -fatih

edit retag flag offensive close merge delete

Comments

Do you have any connectivity to the instance? If not, you need to find out whether the instance has received an IP address and troubleshoot connectivity.

If you do have connectivity, via ping or other means, do you get any error message when trying to ssh into the instance?

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-17 20:54:16 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2017-07-17 06:43:08 -0500

Deepa gravatar image

updated 2017-07-18 03:33:09 -0500

Some versions of Rhel images have login issues .Try Rhel 7.4 or Rhel 6.9 version.You can directly download it from https://docs.openstack.org/image-guid...

edit flag offensive delete link more

Comments

Thanks for your reply. Unfortunately, I must use this version of RHEL. Actually, it is a customized image including some specific stuff which is only supported by 6.6 version. Do you know whether there is any resolution fix for this bug somewhere? Are there other alternatives apart from using anothe

fayvaz gravatar imagefayvaz ( 2017-07-17 11:17:03 -0500 )edit
0

answered 2017-07-18 04:17:56 -0500

TijoV gravatar image

We too faced similar issues, The second build of the instance from the same image worked for us, we were able to shh. Not sure why first time it failed to ssh. Try again if didn't work upload instance logs and Nova-compute log.

edit flag offensive delete link more
0

answered 2017-07-17 20:06:41 -0500

luowei gravatar image

I loaded a CentOs 6.6 image into my stack (which I understand is the equivalent of a rhel 6.6). I pasted the following into the Launch Instance -> Configuration -> Customization Script , which creates a privileged user "myuser" and allows ssh. It worked.

#cloud-config

ssh_pwauth: True
users:
  - name: myuser
    lock-passwd: false
    shell: /bin/bash
    plain_text_passwd: 'mypassword'
    sudo: ALL=(ALL) NOPASSWD:ALL
edit flag offensive delete link more

Comments

luowei gravatar imageluowei ( 2017-07-17 20:11:17 -0500 )edit
0

answered 2017-07-17 11:18:41 -0500

fayvaz gravatar image

Thanks for your reply. Unfortunately, I must use this version of RHEL. Actually, it is a customized image including some specific stuff which is only supported by 6.6 version. Do you know whether there is any resolution fix for this bug somewhere? Are there other alternatives apart from using another RHEL version?

Many thanks, -fatih

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-17 06:32:49 -0500

Seen: 46 times

Last updated: Jul 18