Cinder service on compute not getting recognized at controller- Liberty

asked 2017-07-17 03:57:02 -0500

Lucky gravatar image

Hi, I have installed openstack-liberty via packstack. I configured cinder host as controller as always. Normally cinder would go to all the computes but this time it didn't. I manually installed cinder on computes, configured it as mentioned in guide [also tried via some online links]. But it doesn't get recognized at controller.

    [root@Controller1 ~(keystone_admin)]# cinder service-list
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
|      Binary      |       Host      | Zone |  Status | State |         Updated_at         | Disabled Reason |
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
|  cinder-backup   |   Controller1   | nova | enabled |   up  | 2017-07-17T08:51:32.000000 |        -        |
| cinder-scheduler |   Controller1   | nova | enabled |   up  | 2017-07-17T08:51:30.000000 |        -        |
|  cinder-volume   | Controller1@lvm | nova | enabled |   up  | 2017-07-17T08:51:07.000000 |        -        |
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
[root@Controller1 ~(keystone_admin)]#

Is there something different in liberty release related to Cinder? Am i missing something? I updated cinder.conf and api-paste.ini but didn't work. Please help me resolve this. I can share cinder.conf if the need be.

edit retag flag offensive close merge delete

Comments

Is it running at all? If yes, you should get clues from the cinder-volume log file. Something prevents cinder-volume to contact cinder-api.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-17 06:31:36 -0500 )edit

On the compute, service of cinder is up and logs show that its connected to controller via AMQP. Cinder-api is also running. Anything else you want me to check?

Lucky gravatar imageLucky ( 2017-07-17 10:48:44 -0500 )edit

Still going about the same issue. Checked reinstalling from scratch, reexecuted packstack, shifted to public IPs instead of private IPs. But still same issue. Could you please help me resolve this? In the logs it shows: Connected to AMQP server on 135.249.93.210:5672 Doesn't show up at controller.

Lucky gravatar imageLucky ( 2017-07-23 12:19:08 -0500 )edit