Ask Your Question
0

vcpu number does not reflect cpu_allocation_ratio option

asked 2017-07-13 19:25:42 -0500

zuoziqi gravatar image

The default value in /etc/nova/nova.conf of cpu_allocation_ratio is 0.0, and I set it to 4.0. Then I restart all nova service in compute and controller node. But seems it does not have any effects. The total vcpu number in hypervisor-stat does not change. Is there a known issue about this issue?(I use ocata version of openstack)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-07-13 23:37:48 -0500

Elangovan Anganann gravatar image

Deafult CPU allocation ratio 0.0 means 16.0. You have set it to 4.0. If you have 100 cpu threads, you allocate 400 vCPUs to the VMs. Create VMs and see the overcommit in action. Once vCPU usage reaches 400, you won't be able to create VMs. nova host-describe shows actual CPU threads available and vCPUs used.

edit flag offensive delete link more

Comments

But in horizon dashboard, Hypervisor VCPU show the wrong number,I have 4 cores CPU and with hyper-threaten ,so there will be 8 cores physically, with ratio 4, 32 is expected but there show 8 VCPU in total

zuoziqi gravatar imagezuoziqi ( 2017-07-14 03:02:14 -0500 )edit

It won't change the number of total vcpus on the dashboard, but it will let you go beyond that number. So, it will display "32 used of 8" if you go to your new limit.

luowei gravatar imageluowei ( 2017-07-14 08:49:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2017-07-13 19:25:42 -0500

Seen: 23 times

Last updated: Jul 13