Ask Your Question
0

Tripleo - Controller : Horizon Web URL is not accessible from outside the provision network

asked 2017-07-13 05:32:32 -0500

rajanpauls gravatar image

updated 2017-07-13 05:33:35 -0500

Hi All,

After a long struggle I have installed the Tripleo on a 3 baremetal instance of DELL iDRAC .

1- Undercloud 1- controller 1- Compute

Installation is completed:

Issue: Unable to access the horizion URL from outside the server using web browser.

All ports are opened for http\s, ssh, ping. I can do a ping to Controller Ip, telnet to ssh, http ports, which seems to be opened.

Below are the details of Installation.

UnderCloud:

[stack@inprj-psg14 ~]$ nova list +--------------------------------------+-------------------------+--------+------------+-------------+-------------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+-------------------------+--------+------------+-------------+-------------------------+ | 05f6738e-f85b-4444-8eb5-8ff7660b9aab | overcloud-controller-0 | ACTIVE | - | Running | ctlplane=10.154.202.142 | | 987727c4-d6be-4256-88a0-475e5d0d27a3 | overcloud-novacompute-0 | ACTIVE | - | Running | ctlplane=10.154.202.143 | +--------------------------------------+-------------------------+--------+------------+-------------+-------------------------+

Curl on controller horizon URL is working from undercloud server: [stack@inprj-psg14 ~]$ curl 10.154.202.144 !DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> html> title>301 Moved Permanently /head> h1>Moved Permanently p>The document has moved http://10.154.202.144/dashboard%22%3Ehere (http://10.154.202.144/dashboard">here) /body> [stack@inprj-psg14 ~]$

[stack@inprj-psg14 ~]$ ip a 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: em1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP qlen 1000 link/ether 18:66:da:ec:98:38 brd ff:ff:ff:ff:ff:ff inet 10.154.202.19/25 brd 10.154.202.127 scope global em1 valid_lft forever preferred_lft forever inet6 fe80::1a66:daff:feec:9838/64 scope link valid_lft forever preferred_lft forever 3: em2: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq master ovs-system state UP qlen 1000 link/ether 18:66:da:ec:98:39 brd ff:ff:ff:ff:ff:ff inet6 fe80::1a66:daff:feec:9839/64 scope link valid_lft forever preferred_lft forever 4: em3: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc mq state DOWN qlen 1000 link/ether 18:66:da:ec:98:3a brd ff:ff:ff:ff:ff:ff 5: em4: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc mq state DOWN qlen 1000 link/ether 18:66:da:ec:98:3b brd ff:ff:ff:ff:ff:ff 6: ovs-system: <broadcast,multicast> mtu 1500 qdisc noop state DOWN qlen 1000 link/ether a2:6c:6f:65:4d:02 brd ff:ff:ff:ff:ff:ff 7: br-int: <broadcast,multicast> mtu 1500 qdisc noop state DOWN qlen 1000 link/ether 3a:4d:f4:61:32:4e brd ff:ff:ff:ff:ff:ff 9: br-ctlplane: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000 link/ether 18:66:da:ec:98:39 brd ff:ff:ff:ff:ff:ff inet 10.154.202.134/26 brd 10.154.202.191 scope global br-ctlplane valid_lft forever preferred_lft forever inet6 fe80::1a66:daff:feec:9839/64 scope link valid_lft forever preferred_lft forever 10: docker0: <no-carrier,broadcast,multicast,up ... (more)

edit retag flag offensive close merge delete

Comments

Provide output for this command " openstack catalog list "

TijoV gravatar imageTijoV ( 2017-07-13 23:43:09 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-10-17 06:53:13 -0500

MustafaArif gravatar image

In your network-environment.yaml please check what is the IP address you have mentioned for "ControlPlaneDefaultRoute" tag. If it is Director node IP address you will have director node as a gateway and you will not be able to access horizon from outside network. Change it to your network gateway.

edit flag offensive delete link more
0

answered 2017-07-13 05:44:40 -0500

rajanpauls gravatar image

Can you please be little more specific ?

edit flag offensive delete link more
0

answered 2017-07-13 05:42:48 -0500

TijoV gravatar image

use Load balancer

edit flag offensive delete link more

Comments

Ok,On our Openstack setup, we used 2 Networks 1Private and 1Public. Private network is where all Openstack services installed. Our Dashboard is on Private network. What we did is installed apache LB on our MAAS node and point it as frontend for all Private openstack api ip's. after that abl to acces

TijoV gravatar imageTijoV ( 2017-07-13 23:37:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-13 05:32:32 -0500

Seen: 99 times

Last updated: Oct 17