Ask Your Question
0

How to change Ceilometer reporting SqlAlchemy password

asked 2013-05-13 09:53:41 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, I'm trying to use the SqlAlchemy driver and have found that the password the driver attempts to use is set to ''. This is the password for the driver used by the reporting API, not collection.

I assume this is a default set somewhere, but I can't find it. Have looked through the config and setup files, and tried to find where the CFG object is created.

The reason I know this, is because when the MySQL password is set to something other than '', the driver encounters an MySQL authentication error. When I set the database password (in MySQL for root user) to empty, the driver can authenticate.

My localrc has MYSQL_PASSWORD set to 'password', but the driver can't authenticate when MySQL uses that password.

Anyone know where to set this password for the driver?

Thank you, Eric

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-05-15 07:07:37 -0500

fifieldt gravatar image

As far as I can tell, you set the password in your connection string, through the database_connection option:

eg

database_connection=postgresql://scott:tiger@localhost:5432/mydatabase - where 'tiger' is the password.

edit flag offensive delete link more

Comments

Thanks for the reply. That may work, but would require storing the password in plain text which wouldn't fly around here. I'll give it a try and see if it can get me going in the meantime, thanks.

epende gravatar imageepende ( 2013-05-15 10:05:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-13 09:53:41 -0500

Seen: 179 times

Last updated: May 15 '13