Ask Your Question
0

Unable to log into Horizon in Ocata. Previous solution doesn't work

asked 2017-07-07 16:23:26 -0500

jschaeffer gravatar image

I'm experiencing the problem where I attempt to log into the OpenStack Dashboard but it simply redirects me back to the login page. Apache's error.log file indicates a successful login attempt was made. I know this issue has been seen before and a solution was found in this thread: https://ask.openstack.org/en/question/91642/unable-to-login-to-horizon/?answer=92377#post-id-92377 (https://ask.openstack.org/en/question...)

However, I have copy and pasted the solution in my /etc/openstack-dashboard/local_settings.py configuration file and restarted all my services, but it has not made any difference:

SESSION_ENGINE='django.contrib.sessions.backends.cache'

CACHES = {
    'default': {
       #
        'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',
        'LOCATION': '127.0.0.1:11211',
    }
}

I have memcache listening on localhost on that port:

root@bllcloudctl01:~# ss -tupan | grep 11211
udp    UNCONN     0      0      127.0.0.1:11211                 *:*                  
tcp    LISTEN     0      128    127.0.0.1:11211                 *:*

I'm on Ubuntu 16.04 following the OpenStack Ocata documentation. These are the relevant log files I have been looking at:

/var/log/apache2/error.log

[Fri Jul 07 15:06:49.374597 2017] [wsgi:error] [pid 3689:tid 139784728393472] Attempted scope to domain Default failed, will attemptto scope to another domain.
[Fri Jul 07 15:06:49.622761 2017] [wsgi:error] [pid 3689:tid 139784728393472] Login successful for user "demo", remote address 2603:3026:30d:5600:ed3b:6fcc:280e:6daf.

/var/log/apache2/keystone.log

2017-07-07 15:07:46.832441 2017-07-07 15:07:46.831 3696 INFO keystone.common.wsgi [req-0486459b-c63c-43e7-84de-8c8c51d253e2 - - - - -] POST http://bllcloudctl01:5000/v3/auth/tokens
2017-07-07 15:07:47.082657 2017-07-07 15:07:47.082 3695 INFO keystone.common.wsgi [req-5ed1da5b-531f-4173-988c-46d1a3b4370f d2072b0351954cfc9f2960df1a20c93d - - default -] POST http://bllcloudctl01:5000/v3/auth/tokens
2017-07-07 15:07:47.138713 2017-07-07 15:07:47.138 3695 WARNING keystone.common.wsgi [req-5ed1da5b-531f-4173-988c-46d1a3b4370f d2072b0351954cfc9f2960df1a20c93d - - default -] Authorization failed. The request you have made requires authentication. from 2620:5:e000:201f::2:a
2017-07-07 15:07:47.152907 2017-07-07 15:07:47.152 3692 INFO keystone.common.wsgi [req-c928fdf1-b6a5-4345-aa6e-2a70ca40d4dd - - - - -] GET http://bllcloudctl01:5000/v3/
2017-07-07 15:07:47.170355 2017-07-07 15:07:47.169 3694 INFO keystone.common.wsgi [req-c3dedfba-ed0c-46e8-93d0-a294b0c0ed18 d2072b0351954cfc9f2960df1a20c93d - - default -] GET http://bllcloudctl01:5000/v3/users/d2072b0351954cfc9f2960df1a20c93d/projects
2017-07-07 15:07:47.246885 2017-07-07 15:07:47.246 3696 INFO keystone.common.wsgi [req-25c2a832-9c41-43bf-abf0-366ac6256376 d2072b0351954cfc9f2960df1a20c93d - - default -] POST http://bllcloudctl01:5000/v3/auth/tokens

It is odd to me that is always does a POST to /v3/auth/tokens which fails. When I test the authentication on the command line I see that the process is a GET to /v3 then a POST to /v3/auth/tokens. It appears that the dashboard eventually does this, but it does a POST first, fails, then does the GET, then another POST. I'm assuming this last POST succeeds as there are no additional entries past this point and I see "login successful..." message in the error.log

Is anybody else experiencing this issue on Ocata. Does anybody know of other logs I can check ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-07-09 12:05:54 -0500

rcgelber gravatar image

updated 2017-07-09 13:28:34 -0500

Is that dashboard on the same node as the controller? If so make sure change this and make sure memcached is binding to the management interface (aka the private side of the network) of the controller.

Local_Setting.py

    'LOCATION': '127.0.0.1:11211', <<<<<------------- To  'controller:11211'

Also, move into apache /etc/apache2/apache2.conf and make sure the the following looks like this.

Directory /

    Options FollowSymLinks
    AllowOverride all
    Require all granted

</directory>

Directory /usr/share

    AllowOverride all
    Require all granted

</directory>

Directory /var/www/

    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted

</directory>

edit flag offensive delete link more

Comments

Thanks for your help. I ended up making 2 changes. my <directory> elements in my apache2.conf file were different so I changed them to what you listed. I failed to mention that I was using IPv6, but couldn't get memcache to recognize that in local_settings.py, so I was reverting to IPv4 localhost.

jschaeffer gravatar imagejschaeffer ( 2017-07-12 11:58:10 -0500 )edit

I found a bug on launchpad that shows in order to use IPv6 you have to put 'inet6:[IPV6_ADDR]:PORT' in order for it to work. After I did that I was able to get in.

jschaeffer gravatar imagejschaeffer ( 2017-07-12 11:59:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-07 16:23:26 -0500

Seen: 242 times

Last updated: Jul 09