Ask Your Question
0

Ocata Packstack-Multi Node Config Can't Access VM Instance

asked 2017-07-06 19:12:00 -0500

FeedyRhys gravatar image

updated 2017-07-07 12:57:49 -0500

Created a VM instance - This was successful. Assigned a floating IP also. Can see the console of the instantiated VM.

I cannot seem to hit the VM from my laptop, or on nodes other than the network node. Not sure what to do next in terms of troubleshooting. I can ssh and ping from the network node, but not compute, or control.

IP Spaces -

10.21.200.x - Control, Network, Compute Node locations

ens192 - network nic that connects to physical connection this is assigned for example 10.21.200.4 for control .5 for network .6 for compute

ens224 - internal network nic

192.168.11.x - Private network subnet - That I created in neutron

The following is the config from packstack answer file:

CONFIG_NEUTRON_L3_EXT_BRIDGE=provider    
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vxlan,flat    
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vxlan    
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=openvswitch    
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=extnet:br-ex    
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-ex:ens192    
CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=    
CONFIG_NEUTRON_OVS_EXTERNAL_PHYSNET=extnet    
CONFIG_NEUTRON_OVS_TUNNEL_IF=ens224    
CONFIG_NEUTRON_OVS_TUNNEL_SUBNETS=    
CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789    
CONFIG_PROVISION_OVS_BRIDGE=y

Attached is image of network topology: http://imgur.com/a/MXzHg

ALso when configuring the public and private networks -

neutron net-create public --provider:network_type flat --provider:physical_network extnet --router:external

neutron subnet-create --gateway 10.21.200.1 --allocation-pool start=10.21.200.35,end=10.21.200.50 --disable-dhcp --name public_subnet public 
10.21.200.0/24

neutron  subnet-create private 192.168.11.0/24 --name private_subnet  --enable-dhcp=True --dns-nameserver 8.8.8.8 --dns-nameserver 8.8.4.4

Control - route

    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         gateway         0.0.0.0         UG    0      0        0 ens192
10.21.200.0     0.0.0.0         255.255.254.0   U     0      0        0 ens192
link-local      0.0.0.0         255.255.0.0     U     1002   0        0 ens192
link-local      0.0.0.0         255.255.0.0     U     1003   0        0 ens224
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 ens224

Network -route

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         gateway         0.0.0.0         UG    0      0        0 br-ex
10.21.200.0     0.0.0.0         255.255.254.0   U     0      0        0 br-ex
link-local      0.0.0.0         255.255.0.0     U     1002   0        0 ens192
link-local      0.0.0.0         255.255.0.0     U     1003   0        0 ens224
link-local      0.0.0.0         255.255.0.0     U     1007   0        0 br-ex
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 ens224

netns

.48 is the router .45 is the VM

ip netns
qrouter-1dbfae15-98b7-4c9c-9a7a-b99116d6562e
qdhcp-69a4ea6f-aff7-4f4c-9a7a-bebc1bc3e139

ip netns exec qrouter-1dbfae15-98b7-4c9c-9a7a-b99116d6562e ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
11: qg-204e3bf4-8d: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether fa:16:3e:84:3e:6e brd ff ...
(more)
edit retag flag offensive close merge delete

Comments

You configured the external subnet with 10.21.200/24. On the nodes, you have netmasks 255.255.254.0. Doesn't seem to fit.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-06 22:55:28 -0500 )edit
1

Other steps: Check if instance received IP address. Can you reach its private address from the router and DHCP netns. Can you ping from the instance outside. Trace packets in the netns and the physical interfaces.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-06 22:59:42 -0500 )edit

Hi, Bernd. Fixed netmasks but that didn't seem to fix issue. I posted results of netns for both qrouter and qdhcp.. quick q, should I also be seeing the floating IP in the qdhcp list?

FeedyRhys gravatar imageFeedyRhys ( 2017-07-07 12:37:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-07 13:12:03 -0500

FeedyRhys gravatar image

updated 2017-07-07 13:26:45 -0500

Okay figured it out I think I left out a key point got too wrapped in details :(

If you are building your OpenStack nodes as virtual machines, you must configure the hypervisor to permit promiscuous mode on the external network"

This was done through esxi on vswitch properties -> edit -> security -> promiscuous mode. Toggled to accept.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-06 19:12:00 -0500

Seen: 278 times

Last updated: Jul 07 '17