Ask Your Question
0

ceilometer empty meter-list output

asked 2017-07-05 11:11:36 -0500

Elangovan Anganann gravatar image

Ceilometer meter-list always provides empty list.

[root@controller1 ~ (admin)]# IMAGE_ID=$(glance image-list | grep 'cirros' | awk '{ print $2 }')
[root@controller1 ~ (admin)]# glance image-download $IMAGE_ID > /tmp/cirros.img
You have new mail in /var/spool/mail/root
[root@controller1 ~ (admin)]# ceilometer meter-list
+------+------+------+-------------+---------+------------+
| Name | Type | Unit | Resource ID | User ID | Project ID |
+------+------+------+-------------+---------+------------+
+------+------+------+-------------+---------+------------+

I am using mongodb as the backend in OpenStack (Ocata). Mongodb don't have any data.

> show dbs
admin       0.000GB
ceilometer  0.000GB
local       0.000GB
> use ceilometer
switched to db ceilometer
> db
ceilometer
> show collections
meter
resource
> show dbs
admin       0.000GB
ceilometer  0.000GB
local       0.000GB
> show profile
db.system.profile is empty
Use db.setProfilingLevel(2) will enable profiling
Use db.system.profile.find() to show raw profile entries
> show collections
meter
resource
> db.meter.find()
> show collections
meter
resource
> db.resource.find()
>

I have provided /etc/ceilometer/ceilometer.conf below

[root@controller1 ~ (admin)]# cat /etc/ceilometer/ceilometer.conf
[DEFAULT]
auth_strategy = keystone
transport_url = rabbit://openstack:RABBIT_PASS@10.0.0.11
meter_dispatcher=database


[database]
connection = mongodb://ceilometer:CEILOMETER_DBPASS@10.0.0.33:27017/ceilometer

[keystone_authtoken]
auth_uri = http://10.0.0.11:5000
auth_url = http://10.0.0.11:35357
memcached_servers = 10.0.0.12:11211,10.0.0.13:11211,10.0.0.14:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = ceilometer
password = CEILOMETER_PASS
service_token_roles_required = true

[service_credentials]
auth_type = password
auth_url = http://10.0.0.11:5000/v3
project_domain_name = default
user_domain_name = default
project_name = service
username = ceilometer
password = CEILOMETER_PASS
interface = internalURL
region_name = RegionOne

What could be the issue?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-07-07 22:16:09 -0500

Elangovan Anganann gravatar image

updated 2017-07-07 22:16:54 -0500

I found the issue. Looks like in Ocata release, default value of meter_dispatchers and event_dispatchers is not "database" in ceilometer.conf. Once I added the following configurations, Ceilometer started working.

meter_dispatchers=database
event_dispatchers=database
edit flag offensive delete link more
0

answered 2017-07-06 09:58:26 -0500

Have you configured the glance.conf nova.conf etc making them enable to send metrics to ceilometer ?

edit flag offensive delete link more

Comments

Yes. I have configured glance, nova, cinder, and neutron to send metrics to ceilometer.

Elangovan Anganann gravatar imageElangovan Anganann ( 2017-07-07 22:14:17 -0500 )edit

Please check your logs in /var/log/ceilometer/compute.log provide me with the information what it says.

avinash_k_singh gravatar imageavinash_k_singh ( 2017-07-07 22:25:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-05 11:11:36 -0500

Seen: 423 times

Last updated: Jul 07 '17