Nova-Volume can create volume on Essex

asked 2013-05-13 08:42:19 -0600

ArKam gravatar image

updated 2013-05-13 08:43:23 -0600

Hi there!

I've a little question today. I've setup an OpenStack using Three servers (Dell M610):

One of them is for Cloud Control purpose (Keystone+MySQL+Glance).

The second one is for Cloud Compute purpose (Nova-all except for nova-volume).

And finally, the third one is for Cloud Volume purpose.

Everything is running fine on API/RPC communication layer, however, I'm facing a really strange behavior when I'm trying to create volume.

Indeed, when I'm on the dashboard, or on the CLI and that I start to create a volume, everything is fine BUT my volume still remain in the Creating State for ever.

I've double check my nova.conf and api.conf, everything is fine, all communication are running and my frontend is correctly sending request to my backend nodes.

If I launch a volume-create on the frontend, I correctly see the volume-list on the distant volume node.

I've check date and time parameters and the offset is not exceeding 2ms.

Here is my nova.conf and api-paste.ini files on the Compute Node: (Nova.Conf-Compute) & (Api-paste.Ini-Compute)

Here is my nova.conf file on the Volume Node: (Nova.Conf-Volume)& (Api-paste.Ini-Volume)

As you can see it, I'm using tgtadm as the iSCSI tool and I've check that tgtd service is started.

I also have installed open-iscsi (initiator) and iscsitarget+iscsitarget-dkms (target and module) packages.

all of them have not been edited except for the /etc/default/iscsitarget file that have been set to: TRUE to properly launch the service.

All services are up and running, and all my Openstack stuff are in DEBUG VERBOSE mode but none of them are reporting any kind of error.

There is no trace of any logical volume created on the nova-volumes VG Volume.

I'm suspecting a iscsi issue, but I can't get it so far, then, if you've got some hint/clue/other it'll be really appreciate ;-)

PS: Sorry for the links, I don't seems to have suffisent karma right now :-/.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2013-05-13 09:46:25 -0600

armando-migliaccio gravatar image

With OpenStack Essex and Nova-volume communication between the controller and nova-volume goes via RPC on the message queue. I saw that your nova.conf (for the volume service) points to a MQ running on the localhost. I suspect this is wrong and most likely what's happening is that your request is sitting in the queue being unserved (hence the indefinite CREATING state).


rabbitmqctl list_queues

To verify whether there are pending messages, and ensure your nova-volume is talking to your MQ server.

edit flag offensive delete link more


Thank you very much for your hint, here is what the command return me:

root@VOLUMENODE:~# rabbitmqctl list_queues
Listing queues ...
volume  0
volume_fanout_b7236304613b498f9b4c1941bef3cbcc  0

I don't know what it mean.

ArKam gravatar imageArKam ( 2013-05-13 10:11:41 -0600 )edit

Where is your message queue service? Where is it supposed to run? Run the command there. Both your compute's and volume's nova.conf have rabbit_host=localhost. That can't be right.

armando-migliaccio gravatar imagearmando-migliaccio ( 2013-05-13 11:33:47 -0600 )edit

You were right! Many thanks for your help :D You're educated guess was the right one! I've swap from localhost to frontend.domain.tld where our RabbitMQ Main server is up and running and the volume is correctly set right now!

In fact, I didn't correctly understood this messaging concept, Now it OK.

ArKam gravatar imageArKam ( 2013-05-14 03:02:25 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-05-13 08:42:19 -0600

Seen: 224 times

Last updated: May 13 '13