Ask Your Question
0

DevStack glance error at install

asked 2017-07-04 08:10:52 -0600

Hobotronic gravatar image

Hey, I get this error everytime I try to run ./stack on any branch:

Obtaining file:///opt/stack/glance
 Exception:
 Traceback (most recent call last):
 File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
 status = self.run(options, args)
 File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 335, in run
 wb.build(autobuilding=True)
 File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
 self.requirement_set.prepare_files(self.finder)
 File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
 ignore_dependencies=self.ignore_dependencies))
 File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 521, in _prepare_file
 req_to_install.check_if_exists()
 File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1036, in check_if_exists
 self.req.name
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 558, in get_distribution
 dist = get_provider(dist)
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 432, in get_provider
 return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 968, in require
 needed = self.resolve(parse_requirements(requirements))
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 859, in resolve
 raise VersionConflict(dist, req).with_context(dependent_req)
 ContextualVersionConflict: (keystoneauth1 2.4.3 (/usr/local/lib/python2.7/dist-packages), 
 Requirement.parse('keystoneauth1>=2.16.0'), set(['castellan']))
 +inc/python:pip_install:1                  exit_trap
 +./stack.sh:exit_trap:491                  local r=2
 ++./stack.sh:exit_trap:492                  jobs -p
 +./stack.sh:exit_trap:492                  jobs=
 +./stack.sh:exit_trap:495                  [[ -n '' ]]
 +./stack.sh:exit_trap:501                  kill_spinner
 +./stack.sh:kill_spinner:387               '[' '!' -z '' ']'
 +./stack.sh:exit_trap:503                  [[ 2 -ne 0 ]]
 +./stack.sh:exit_trap:504                  echo 'Error on exit'
 Error on exit
 +./stack.sh:exit_trap:505                  generate-subunit 1499173157 64 fail
 +./stack.sh:exit_trap:506                  [[ -z /opt/stack/logs ]]
 +./stack.sh:exit_trap:509                  /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs
 World dumping... see /opt/stack/logs/worlddump-2017-07-04-130022.txt for details
 +./stack.sh:exit_trap:515                  exit 2
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-04 14:51:10 -0600

Tiago Farias gravatar image

updated 2017-07-04 14:52:07 -0600

You need to upgrade the package keystoneauth1, because the version that you have in your system is: 2.4.3 And Glance needs version: >=2.16.0.

Try the following:

pip install 'keystoneauth1>=2.16.0'

But I think you will have more error like that in the future.

I have had the same erros with Devstack, after rebuild it multiple times, The only solution was to reinstall my enviroment and start again, but maybe you have more luck than me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-04 08:10:52 -0600

Seen: 995 times

Last updated: Jul 04 '17