Ask Your Question

DevStack glance error at install

asked 2017-07-04 08:10:52 -0600

Hobotronic gravatar image

Hey, I get this error everytime I try to run ./stack on any branch:

Obtaining file:///opt/stack/glance
 Traceback (most recent call last):
 File "/usr/local/lib/python2.7/dist-packages/pip/", line 215, in main
 status =, args)
 File "/usr/local/lib/python2.7/dist-packages/pip/commands/", line 335, in run
 File "/usr/local/lib/python2.7/dist-packages/pip/", line 749, in build
 File "/usr/local/lib/python2.7/dist-packages/pip/req/", line 380, in prepare_files
 File "/usr/local/lib/python2.7/dist-packages/pip/req/", line 521, in _prepare_file
 File "/usr/local/lib/python2.7/dist-packages/pip/req/", line 1036, in check_if_exists
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/", line 558, in get_distribution
 dist = get_provider(dist)
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/", line 432, in get_provider
 return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/", line 968, in require
 needed = self.resolve(parse_requirements(requirements))
 File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/", line 859, in resolve
 raise VersionConflict(dist, req).with_context(dependent_req)
 ContextualVersionConflict: (keystoneauth1 2.4.3 (/usr/local/lib/python2.7/dist-packages), 
 Requirement.parse('keystoneauth1>=2.16.0'), set(['castellan']))
 +inc/python:pip_install:1                  exit_trap
 +./                  local r=2
 ++./                  jobs -p
 +./                  jobs=
 +./                  [[ -n '' ]]
 +./                  kill_spinner
 +./               '[' '!' -z '' ']'
 +./                  [[ 2 -ne 0 ]]
 +./                  echo 'Error on exit'
 Error on exit
 +./                  generate-subunit 1499173157 64 fail
 +./                  [[ -z /opt/stack/logs ]]
 +./                  /opt/stack/devstack/tools/ -d /opt/stack/logs
 World dumping... see /opt/stack/logs/worlddump-2017-07-04-130022.txt for details
 +./                  exit 2
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-07-04 14:51:10 -0600

Tiago Farias gravatar image

updated 2017-07-04 14:52:07 -0600

You need to upgrade the package keystoneauth1, because the version that you have in your system is: 2.4.3 And Glance needs version: >=2.16.0.

Try the following:

pip install 'keystoneauth1>=2.16.0'

But I think you will have more error like that in the future.

I have had the same erros with Devstack, after rebuild it multiple times, The only solution was to reinstall my enviroment and start again, but maybe you have more luck than me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-07-04 08:10:52 -0600

Seen: 1,025 times

Last updated: Jul 04 '17