Ask Your Question
0

noVNC proxy broken on one controller

asked 2017-07-03 16:09:38 -0500

Damian Dąbrowski gravatar image

Hello,

I've deployed my environment by fuel. One time i've broken my controller, so i removed it and deployed again. From this time, when service nova-novncproxy is started on this controller, it breaks availability of noVNC via horizon(gray sceen with 'loading...'). When I disable nova-novncproxy on this controller - all works fine again.

I've spent all day on trying to fix it but I don't have any idea. I would be grateful for any help.

iptables -vnL | grep 6080 on all controllers

ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport ports 8774,8776,6080 /* 105 nova */

command grep 'vnc' /etc/nova/nova.conf on:

working controller node:

novncproxy_host=172.29.0.9
novncproxy_port=6080
[vnc]
novncproxy_base_url=http://172.29.0.9:6080/vnc_auto.html

broken controller node

novncproxy_host=172.29.0.5
novncproxy_port=6080
[vnc]
novncproxy_base_url=http://172.29.0.5:6080/vnc_auto.html

grep 'vnc' /etc/nova/nova.conf on compute node

[vnc]
vncserver_proxyclient_address=172.29.0.8
vncserver_listen=0.0.0.0
novncproxy_base_url=https://myopenstack.com:6080/vnc_auto.html

iptables -vnL | grep 'nova' on compute node

ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport ports 8774,8776,6080 /* 105 nova */
ACCEPT     tcp  --  *      *       172.29.0.0/24        0.0.0.0/0            multiport ports 8775,5900:6900 /* 105 nova internal - no ssl from 172.29.0.0/24 */
ACCEPT     tcp  --  *      *       172.29.0.0/24        0.0.0.0/0            multiport ports 5900:6900 /* 105 nova vnc from 172.29.0.0/24 */
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2017-07-04 14:48:57 -0500

Damian Dąbrowski gravatar image

Hi,

I've figured out the problem. Newly deployed controller has newer packages. Problem was caused by difference in novnc version. When I've deployed all 3 controllers again at the same time, they got exactly the same version of packages and all started to work.

edit flag offensive delete link more
0

answered 2017-07-04 15:06:23 -0500

Tiago Farias gravatar image

Have tried to stop the firewall just in case?

I have my enviroment working using the configuration below.

My nova.conf configuration is:

Controller node: 192.168.209.100

[vnc]

vncserver_listen = 192.168.209.100

vncserver_proxyclient_address = 192.168.209.100

novncproxy_host=0.0.0.0

novncproxy_port=6080

novncproxy_base_url=http://192.168.209.100:6080/vnc_auto.html

Compute node: 192.168.209.101

[vnc]

vncserver_listen = 0.0.0.0

vncserver_proxyclient_address = 192.168.209.101

novncproxy_base_url = http://192.168.209.100:6080/vnc_auto.html (http://192.168.209.100:6080/vnc_auto....)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-03 16:09:38 -0500

Seen: 321 times

Last updated: Jul 04 '17