Can't access metadata store http://169.254.169.254 [closed]

asked 2014-01-22 06:59:39 -0500

DaveJ gravatar image

I have performed a multi-node install using Packstack. I have 3 boxes, a Controller, Network Controller and Compute node.

Within my project I have created a private network 10.0.76.0/24, which uses segmentation ID 76.

When I boot an instance, it can't contact the metadata store on the usual http://169.254.169.254 instead, it reverts to the private network metadata store http://10.0.76.21

While this works, I would prefer to use the one central meta-data store (169.254.169.254). Is there specific configuration required to enable this, or do I need to setup some routing rules? The problem this causes for me, is it takes longer for images to boot, as they spend time trying to contact the inital 169.254.169.254 store.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by larsks
close date 2014-04-03 13:46:26.262002

Comments

What kind of network do you use ? Flat, FlatDHCP or Quantum/Neutron ?

salvorapi gravatar imagesalvorapi ( 2014-01-22 08:22:07 -0500 )edit

Neutron + provider router with tenant networking. I haven't actually setup a router or the external network, but I didn't think that was necessary for the metastore.

DaveJ gravatar imageDaveJ ( 2014-01-22 08:32:37 -0500 )edit

If you use Quantum with GRE network you have to setup a router that have external network (ext_net) as gateway.

salvorapi gravatar imagesalvorapi ( 2014-01-23 02:06:36 -0500 )edit

I'm using OVS with VLANs as opposed to GRE. I went ahead an setup the ext_net, and verified it was working by attaching a floating IP. My instances still can't access the metadata store on http://169.254.169.254. What am I missing here ? N.B I've set this in the neutron dhcp config 'enable_metadata_network = True'

DaveJ gravatar imageDaveJ ( 2014-01-24 08:06:44 -0500 )edit

Try to edit the question adding more details there instead as comments: makes the question a lot more readable.

smaffulli gravatar imagesmaffulli ( 2014-01-24 11:35:06 -0500 )edit