Ask Your Question
1

Ocata The placement API endpoint not found on Ubuntu [closed]

asked 2017-07-02 22:03:56 -0500

ch155260 gravatar image

I have issue about Resource Providers. I had restarted nova-compute service on Compute node, but didn't have any error code or fail messages.

When using command nova-status --debug upgrade checkon Control node, I received the message of resource Providers warning as below.

I don't have any idea to solve the issue. Who can help to solve this issue or know how to fix it? Thank you.

Control node

nova-status --debug upgrade check

+-------------------------------------------------------------------+
| Upgrade Check Results                                             |
+-------------------------------------------------------------------+
| Check: Cells v2                                                   |
| Result: Success                                                   |
| Details: None                                                     |
+-------------------------------------------------------------------+
| Check: Placement API                                              |
| Result: Success                                                   |
| Details: None                                                     |
+-------------------------------------------------------------------+
| Check: Resource Providers                                         | 
| Result: Warning                                                   |
| Details: There are no compute resource providers in the Placement |
|   service but there are 1 compute nodes in the deployment.        |
|   This means no compute nodes are reporting into the              |
|   Placement service and need to be upgraded and/or fixed.         |
|   See                                                             |
|   http://docs.openstack.org/developer/nova/placement.html         |
|   for more details.                                               |
+-------------------------------------------------------------------+

/etc/nova/nova.conf

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
force_dhcp_release=true
state_path=/var/lib/nova
enabled_apis=osapi_compute,metadata
log_dir=/var/log/nova
transport_url = rabbit://openstack:RABBIT_PASS@master
my_ip = 10.1.111.170
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
[api]
auth_strategy = keystone
[api_database]
connection = mysql+pymysql://nova:111111@master/nova_api
[database]
connection = mysql+pymysql://nova:111111@master/nova
[glance]
api_servers = http://master:9292
[keystone_authtoken]
auth_uri = http://master:5000
auth_url = http://master:35357
memcached_servers = master:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = 111111
[placement]
s_region_name = RegionOne
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://master:35357/v3
username = placement
password = 111111
[scheduler]
discover_hosts_in_cells_interval  =  300
[vnc]
enabled  =  true
vncserver_listen  =  $ my_ip
vncserver_proxyclient_address  =  $ my_ip
[wsgi]
api_paste_config=/etc/nova/api-paste.ini

Cmpute node

/etc/nova/nova.conf

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
force_dhcp_release=true
state_path=/var/lib/nova
enabled_apis=osapi_compute,metadata
log_dir=/var/log/nova
transport_url = rabbit://openstack:RABBIT_PASS@master
my_ip = 10.1.111.102
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
[api]
auth_strategy = keystone
[api_database]
connection=sqlite:////var/lib/nova/nova.sqlite
[cells]
enable=False
[glance]
api_servers = http://master:9292
[keystone_authtoken]
auth_uri = http://master:5000
auth_url = http://master:35357
memcached_servers = master:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = 111111
[libvirt]
virt_type = qemu
[oslo_concurrency]
lock_path=/var/lib/nova/tmp
[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://masterr:35357/v3
username = placement
password = 111111
[vnc]
enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = $my_ip
novncproxy_base_url = http://master:6080/vnc_auto.html
[wsgi]
api_paste_config=/etc/nova/api-paste.ini

/var/log/nova-compute.log

2017-07-03 10:58:52.456 32223 WARNING nova.virt.libvirt.driver [-] The libvirt driver is not tested on kvm/aarch64 by the OpenStack project and thus its quality can not be ensured. For more information, see: http://docs.openstack.org/developer/nova/support-matrix.html
2017-07-03 10:58:52.709 32223 WARNING nova.compute.monitors [req-0c3773a1-4eaa-4a0e-ad57-d563c4e20778 - - - - -] Excluding nova.compute.monitors.cpu monitor virt_driver. Not in the list of enabled monitors (CONF.compute_monitors).
2017-07-03 10:58:53.464 32223 WARNING keystoneauth.identity ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by ch155260
close date 2017-07-04 20:42:40.599296

Comments

This message explains why the placement database is empty: Placement API service is not responding. My guess: Placement API config on controller and compute nodes is not in sync. Or perhaps something blocks the Placement port on the controller.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-02 22:16:17 -0500 )edit

Well, here is your error:

[placement]
s_region_name = RegionOne

It should be os_region_name.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-02 22:21:01 -0500 )edit

Hi Bernd Bausch, Thanks for reply.I fix the os_region_name still can't work.I don't have firwall on Ubuntu 16.04 and port 8778 is work.http://imgur.com/a/Apvdh (link text) How can I do for that? ->Placement API config on controller and compute nodes is not in sync.

ch155260 gravatar imagech155260 ( 2017-07-02 22:58:02 -0500 )edit

This looks wrong as well: auth_url = http://masterr:35357/v3.

Also double-check the placement service endpoints.

Bernd Bausch gravatar imageBernd Bausch ( 2017-07-03 01:14:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-04 20:41:55 -0500

ch155260 gravatar image

I rebuild Openstack follow Openstack official website document is workable. I think is config setting some wrong.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-07-02 22:03:56 -0500

Seen: 2,056 times

Last updated: Jul 04 '17