Unable to create instance

asked 2017-06-30 07:05:34 -0500

ygk gravatar image

updated 2017-06-30 13:24:04 -0500

Hi All,

I have a packstack setup of newton openstack on three nodes. Controller, compute and network nodes. When I use tenant network of type vxlan, it is working fine. But when I change the tenant network type in ml2.conf to 'vlan', the instance creation is failing.

The neutron logs show this:

2017-06-30 07:43:09.964 39076 ERROR neutron.plugins.ml2.managers [req-ea365127-7798-48ad-9b3f-adcde3e075ee 43963a5dfc084e819c2e3cd6b8cffb93 4457cb0b375345cdb8a23e2ed0c0dc83 - - -] Failed to bind port e8fcd9a6-5b03-46cc-a777-0a92496108ac on host compute for vnic_type normal using segments [{'segmentation_id': 70, 'physical_network': u'br-ens38', 'id': u'cb25d3c8-24db-4366-8d0d-1c30832e2846', 'network_type': u'vlan'}]

These are my configurations from compute node:


[root@compute ~]# cat /etc/neutron/plugins/ml2/openvswitch_agent.ini |  grep -v '^$\|#'
[DEFAULT]
[agent]
tunnel_types =vxlan
vxlan_udp_port = 4789
l2_population = False
drop_flows_on_start = False
[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.91.130
bridge_mappings = physnet1:br-ens38
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
----------------

[root@compute ~]# ovs-vsctl show
7f3ba819-2fea-436b-806f-5e546e5c31ae
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-tun
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "vxlan-c0a85b83"
            Interface "vxlan-c0a85b83"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.91.130", out_key=flow, remote_ip="192.168.91.131"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "int-br-ens38"
            Interface "int-br-ens38"
                type: patch
                options: {peer="phy-br-ens38"}
        Port br-int
            Interface br-int
                type: internal
    Bridge "br-ens38"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "br-ens38"
            Interface "br-ens38"
                type: internal
        Port "phy-br-ens38"
            Interface "phy-br-ens38"
                type: patch
                options: {peer="int-br-ens38"}
    ovs_version: "2.6.1"
---------------------

These are the configuration from network node:

[root@network ~]#  cat /etc/neutron/plugins/ml2/openvswitch_agent.ini |  grep -v '^$\|#'
[DEFAULT]
[agent]
tunnel_types =vxlan
vxlan_udp_port = 4789
l2_population = False
drop_flows_on_start = False
[ovs]
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.91.131
bridge_mappings = physnet1:br-ens38
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[root@network ~]#
[root@network ~]# ovs-vsctl show
b1ba7d87-571f-4ec4-a95c-564410baaef8
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-tun
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "vxlan-c0a85b82"
            Interface "vxlan-c0a85b82"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.91.131", out_key=flow, remote_ip="192.168.91.130"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
    Bridge "br-ens38"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "phy-br-ens38"
            Interface "phy-br-ens38"
                type: patch
                options: {peer="int-br-ens38"}
        Port "br-ens38"
            Interface "br-ens38"
                type: internal
        Port "ens38"
            Interface "ens38"
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "int-br-ens38"
            Interface "int-br-ens38"
                type: patch
                options: {peer="phy-br-ens38"}
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.6.1"
[root@network ~]#
---------------------------------

What is causing this error ? Please helpenter code here

edit retag flag offensive close merge delete

Comments

Hi All,

I am able to create the vlan networks now. But my vm is not getting dhcp ip if it is launched on vlan network., whereas, It is getting the ip when launched on vxlan network. Also I see only two ovs rules on the vlan bridge whereas more rules on br-tun bridge

ygk gravatar imageygk ( 2017-07-04 06:48:18 -0500 )edit

Can anyone help me please ?

ygk gravatar imageygk ( 2017-07-04 06:51:58 -0500 )edit

I have installed packstack on vmware workstation. I have created controller, compute and network node vms. Do you think the tagged vlans are getting blocked by the vmware virtual networks between the compute and network nodes ? Is it possible to have working vlan networks of openstack on vm nodes

ygk gravatar imageygk ( 2017-07-04 08:25:24 -0500 )edit