Problem when trying to create an instance on top of LXD 2.13 or 2.15

asked 2017-06-30 05:02:17 -0500

panos gravatar image

Hello,

We are trying to create an instance on top of LXD>= 2.13 (either through the Dashboard or command line) but it fails with "no valid host available" error indication in the Dashboard. When we try with older versions of LXD (i.e., 2.0.9 and 2.0.10) the instance is created normally, but when we update to newer versions I get the error. Searching for the problem in the logs we found out that there is a Neutron related issue with LXD>=2.13. Particularly the source of the problem seems to be that the qbr, qvo interfaces to the Linux and integration bridge respectively are not created normally. More specifically I get the following in the syslogs:

Could not generate persistent MAC address for qbr52ecbb0d-f0: No such file or directory Could not generate persistent MAC address for qvo52ecbb0d-f0: No such file or directory Could not generate persistent MAC address for qvb52ecbb0d-f0: No such file or directory

Could you tell me how to deal with this issue? The reason why we need a newer version of LXD than 2.0.9 or 2.0.10 is because later I need to support a USB passthrough through the virtual instance which is not supported for these old versions.

Thanks a lot in advance,

Panos.

edit retag flag offensive close merge delete