Ask Your Question
0

Getting binding_failed on router to VLAN provider Network (Open Vswitch)

asked 2017-06-29 08:41:43 -0600

pwd gravatar image

updated 2017-06-30 11:15:37 -0600

I am trying to set up a cluster of Openstack systems and started with a single node, on that node that is working I used a flat provider network to keep it simple but I need to set up a vlan provider network.

On the second node that I created for testing like the first as a all-in-one system I first got the OpenVswitch working to support the VLANS on the host computer before even trying to get OpenStack working and have done so. I then created a new Region (wanting to keep my first running stack up for now) and got to the point of creating the first router between an internal network (on the admin project for now) and the provider network (called home-net) I create the router but get. the following on the gateway port.

[pwd@pwd-stack-1 ~(keystone_admin)]$ openstack port show 39ec7053-2d56-4ff6-9ea4-87bc3b1ab170
+-----------------------+---------------------------------------------------------------------------+
| Field                 | Value                                                                     |
+-----------------------+---------------------------------------------------------------------------+
| admin_state_up        | UP                                                                        |
| allowed_address_pairs |                                                                           |
| binding_host_id       | pwd-stack-1.frame.biz                                                     |
| binding_profile       |                                                                           |
| binding_vif_details   |                                                                           |
| binding_vif_type      | binding_failed                                                            |
| binding_vnic_type     | normal                                                                    |
| created_at            | 2017-06-29T12:53:53Z                                                      |
| description           |                                                                           |
| device_id             | 356abdd1-8bbb-4de1-99b8-df9e8d3759a4                                      |
| device_owner          | network:router_gateway                                                    |
| dns_assignment        | None                                                                      |
| dns_name              | None                                                                      |
| extra_dhcp_opts       |                                                                           |
| fixed_ips             | ip_address='10.72.10.2', subnet_id='3aa89106-e623-46b4-8aed-054628035bdd' |
| id                    | 39ec7053-2d56-4ff6-9ea4-87bc3b1ab170                                      |
| ip_address            | None                                                                      |
| mac_address           | fa:16:3e:d4:81:8a                                                         |
| name                  |                                                                           |
| network_id            | 1d935e53-41bd-49cc-be4b-2eb23fe2d738                                      |
| option_name           | None                                                                      |
| option_value          | None                                                                      |
| port_security_enabled | False                                                                     |
| project_id            |                                                                           |
| qos_policy_id         | None                                                                      |
| revision_number       | 4                                                                         |
| security_groups       |                                                                           |
| status                | DOWN                                                                      |
| subnet_id             | None                                                                      |
| updated_at            | 2017-06-29T12:53:56Z                                                      |
+-----------------------+---------------------------------------------------------------------------+

my openvswitch bridge is called br-ovs0 and (clearing comments and blank lines from the config files) I show:

[pwd@pwd-stack-1 ~(keystone_admin)]$ sudo grep -v '#' /etc/neutron/plugin.ini | grep -v -e '^[[:space:]]*$'
[DEFAULT]
[ml2]
type_drivers = vxlan,flat,vlan,gre
tenant_network_types = vxlan
mechanism_drivers =openvswitch
path_mtu = 0
[ml2_type_flat]
flat_networks = *
[ml2_type_geneve]
[ml2_type_gre]
tunnel_id_ranges =
[ml2_type_vlan]
network_vlan_ranges = br-ovs0
[ml2_type_vxlan]
vni_ranges =300:600
vxlan_group = 224.0.0.1
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True

[pwd@pwd-stack-1 ~(keystone_admin)]$ sudo grep -v '#' /etc/neutron/neutron.conf | grep -v -e '^[[:space:]]*$'
[DEFAULT]
bind_host=0.0.0.0
auth_strategy=keystone
core_plugin=neutron.plugins.ml2.plugin.Ml2Plugin
service_plugins=router,metering
allow_overlapping_ips=True
notify_nova_on_port_status_changes=True
notify_nova_on_port_data_changes=True
api_workers=24
rpc_workers=24
router_scheduler_driver=neutron.scheduler.l3_agent_scheduler.ChanceScheduler
l3_ha=False
max_l3_agents_per_router=3
debug=False
log_dir=/var/log/neutron
transport_url=rabbit://guest:guest@10.73.1.111:5672/
rpc_backend=rabbit
control_exchange=neutron
[agent]
root_helper=sudo neutron-rootwrap /etc/neutron/rootwrap.conf
[cors]
[cors.subdomain]
[database]
connection=mysql+pymysql://neutron:042fbc2e9ed94b66@10.73.1.111/neutron
[keystone_authtoken]
auth_uri=http://10.73.1.111:5000/v3
auth_type=password
auth_url=http://10.73.1.111:35357
username=neutron
password=XXXXXXXXXXXXXXXXXXXX
user_domain_name=Default
project_name=services
project_domain_name=Default
[matchmaker_redis]
[nova]
region_name=AtlPwd1
auth_url=http://10.73.1.111:35357
auth_type=password
password=XXXXXXXXXXXXXXXXXXXX
project_domain_id=default
project_domain_name=Default
project_name=services
tenant_name=services
user_domain_id=default
user_domain_name=Default
username=nova
[oslo_concurrency]
lock_path=$state_path/lock
[oslo_messaging_amqp]
[oslo_messaging_kafka]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
rabbit_use_ssl=False
[oslo_messaging_zmq]
[oslo_middleware]
[oslo_policy]
policy_file=/etc/neutron/policy.json
[qos]
[quotas]
[ssl]
[service_providers]

[pwd@pwd-stack-1 ~(keystone_admin)]$ openstack router list
+--------------------------------------+-----------+--------+-------+-------------+-------+----------------------------------+
| ID                                   | Name      | Status | State | Distributed | HA    | Project                          |
+--------------------------------------+-----------+--------+-------+-------------+-------+----------------------------------+
| 356abdd1-8bbb-4de1-99b8-df9e8d3759a4 | home-test | ACTIVE | UP    | False       | False | f82c693f83934651bfcb40ae2453b77b |
+--------------------------------------+-----------+--------+-------+-------------+-------+----------------------------------+
[pwd@pwd-stack-1 ~(keystone_admin)]$ openstack router show home-test
+-------------------------+-----------------------------------------------------------------------------------------------------------+
| Field                   | Value                                                                                                     |
+-------------------------+-----------------------------------------------------------------------------------------------------------+
| admin_state_up          | UP                                                                                                        |
| availability_zone_hints |                                                                                                           |
| availability_zones      | nova                                                                                                      |
| created_at              | 2017-06-29T12:53:02Z                                                                                      |
| description             |                                                                                                           |
| distributed             | False                                                                                                     |
| external_gateway_info ...
(more)
edit retag flag offensive close merge delete

Comments

grep the neutron logs for the port ID to get clues why the binding failed.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-29 10:12:23 -0600 )edit

network_vlan_ranges = br-ovs0 <-- should be something with a range: br-ovs0:500:600. may not the complete solution, just an error I spotted.

Andreas Merk gravatar imageAndreas Merk ( 2017-06-30 03:24:41 -0600 )edit

I tried changing the network_vlan_ranges to br-ovs0:70:80

Deleted and re-created the router and still get the same error (the ID of the port changed of course)

I will edit the original post to add the log output.

pwd gravatar imagepwd ( 2017-06-30 11:11:29 -0600 )edit

This part of the error 'physical_network': u'br-ovs0'indicates that your bridge mapping in the openvswitch agent file is incorrect. The value of physical_network should not be the bridge.See step 4 in https://docs.openstack.org/ocata/netw....

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-30 20:24:50 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-01 14:39:29 -0600

pwd gravatar image

The problem was that I did not use the mapping (used the bridge name) when I

1) created the network

and (and I think that this is important)

2) set the network_vlan_range (at first it was blank then it had br-ovs0 then br-ovs0:70:80

it should be network_vlan_ranges = extnet:70:80

Anyway it is working now and I think that I understand what I did wrong.

thanks for the help

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-29 08:41:43 -0600

Seen: 132 times

Last updated: Jul 01 '17