Ask Your Question
0

Horizon Problem in Newton

asked 2017-06-28 07:08:33 -0500

Eric Rakotonirina gravatar image

updated 2017-06-28 07:09:22 -0500

Hello all,

I've successfully installed a clustered Openstack newton on centos 7 using pacemaker with 3 controller nodes and 2 compute node. Since 2 months, horizon was functionning good. but actually, i've a strange problem: -- all actions done through horizon are not seen in CLI and -- all actions done through cli are no seen in horizion dashboard

Some examples: if I create a network in dashboard, openstack network list show nothing if I a launch an instance from cli , it is not present in dashboard

all the actions above are done with the same account under the same project.

Anyone has experienced this ?

thx :) Eric

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-06-28 15:05:33 -0500

Are you sure you are working with the same user on the same tenant both from CLI and GUI? You could check that comparing what tenant you have configured in your rc file with the tenant you see in Horizon.

edit flag offensive delete link more

Comments

hello Antonio, yes. I'm sure. i use the admin user. It's the same with other user. Is it not a Horizon not syncing to the database?

Eric Rakotonirina gravatar imageEric Rakotonirina ( 2017-06-29 02:07:40 -0500 )edit

It is OK now after restarting the entire cluster. But i've another problem: When i am on dashboard , when i try to browse another page randomly, it logged me out. I need to re enter my credentials and again redo my action and again it looged me out. really strange

Eric Rakotonirina gravatar imageEric Rakotonirina ( 2017-06-29 03:40:56 -0500 )edit
0

answered 2017-06-29 02:11:29 -0500

Eric Rakotonirina gravatar image

You can see it in this exemple:

  [root@controller1 ~(keystone_admin)]# openstack server list
+--------------------------------------+------+--------+-----------------------+------------+
| ID                                   | Name | Status | Networks              | Image Name |
+--------------------------------------+------+--------+-----------------------+------------+
| ca95b873-12fc-46a4-a822-7b23d8d4117d | web2 | ACTIVE | provider=10.103.0.111 | cirros     |
| 255c12f4-8a36-44a2-9c9a-cc4a02353ab5 | web1 | ACTIVE | provider=10.103.0.105 | cirros     |
+--------------------------------------+------+--------+-----------------------+------------+

But the dashboard show nothing .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-28 07:08:33 -0500

Seen: 122 times

Last updated: Jun 29 '17