Ask Your Question
0

Availability Zone Name Not Updating

asked 2014-01-21 17:45:43 -0500

amitlalani gravatar image

Have 1 Openstack Controller and 2 Compute Nodes Running Havana.

I want to split Compute Nodes(001 and 002) into two different Availability Zones.

I have set nova.conf on compute-002 to have node_availability_zone=compute002 and restarted nova-compute and api services.

However the Controller does not seem to reflect these changes.

>> nova-manage service list
Binary           Host                                 Zone             Status     State 
nova-cert        it-openstack-controller-001          internal         enabled    :-)   
nova-consoleauth it-openstack-controller-001          internal         enabled    :-) 
nova-scheduler   it-openstack-controller-001          internal         enabled    :-) 
nova-network     it-openstack-controller-001          internal         enabled    :-)   
nova-conductor   it-openstack-controller-001          internal         enabled    :-)  
nova-compute     it-openstack-compute-001             nova             enabled    :-) 
nova-network     it-openstack-compute-001             internal         enabled    :-)
nova-compute     it-openstack-compute-002             nova             enabled    :-)
nova-network     it-openstack-compute-002             internal         enabled    :-)

Any ideas on what is going wrong here?

Thanks

edit retag flag offensive close merge delete

Comments

The availability zone for compute should be specified using 'default_availability_zone' config parameter.

unmesh-gurjar gravatar imageunmesh-gurjar ( 2014-01-21 23:59:42 -0500 )edit

Hi Unmesh, I tried to set 'default_availability_zone' flag in nova.conf of compute nodes but still it didn't work for me. can you please suggest some other way to do it

RomilGupta gravatar imageRomilGupta ( 2014-01-22 02:15:56 -0500 )edit

Thanks for the response, have made the change and restarted the services but still no ball.

amitlalani gravatar imageamitlalani ( 2014-01-22 04:01:08 -0500 )edit

set 'default_availability_zone' flag in nova.conf of controller nodes and restart nova services

anshbikram gravatar imageanshbikram ( 2016-07-12 00:37:36 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-04-17 10:10:44 -0500

gounini gravatar image

Since Grizzly, AZ are special Host Aggregate. You have to create a aggregate specifying his AZ.

nova aggregate-create AG1 AZ1 nova aggregate-add-host AG1 host1 ...

edit flag offensive delete link more
1

answered 2014-01-22 06:09:53 -0500

amitlalani gravatar image

Got it to work by following this guide: http://russellbryantnet.wordpress.com/2013/05/21/availability-zones-and-host-aggregates-in-openstack-compute-nova/ (http://russellbryantnet.wordpress.com...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-21 17:45:43 -0500

Seen: 2,280 times

Last updated: Apr 17 '14