Ask Your Question
1

Object not found when increase partition power openstack swift

asked 2017-06-25 21:27:10 -0500

Cuong Nguyen gravatar image

I have just increased partition power openstack swift. But after incrementing the partition power, the objects not found. I can not download previously existing objects in the cluster. Is there a way to fix this and let me know the best way to increase partition power. I have reference link https://github.com/redhat-cip/swift-r...

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-24 22:46:51 -0500

notmyname gravatar image

Unless you're using a pre-release version of the "increase part power" feature that's going to be in 2.14.0 (https://review.openstack.org/#/c/337297/), then you should immediately set the part power back to its original value and redeploy your rings. If you're lucky and haven't done too much else to your cluster (including adding or deleting objects), then the damage should be limited. Any PUT, POST, or DELETE operations you've done are likely going to need to be replayed after you reset the ring part power.

If you need to increase the ring part power, please make sure you are using the feature that has landed upstream and follow the instructions at https://docs.openstack.org/swift/late... very carefully.

edit flag offensive delete link more

Comments

Thanks for your answer. I have increased successfully.

Cuong Nguyen gravatar imageCuong Nguyen ( 2017-07-25 04:20:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-25 21:27:10 -0500

Seen: 133 times

Last updated: Jul 24 '17