Newton create VM - Failed to Bind Port, No valid host found

asked 2017-06-22 10:53:57 -0500

Lucky gravatar image

Hi, I have installed an all-in-one setup of openstack-newton using packstack. I'm trying to launch a cirros vm, which gets failed with error "No valid host found" on dashboard. Checking neutron logs it says, failed to bind port. Could someone please help me out? I tried multiple solutions but couldn't get through.

Error is as follows:

PortBindingFailed: Binding failed for port 8056eb45-1122-4ba6-86ed-223f45c0109c, please check neutron logs for more information

ERROR neutron.agent.linux.async_process [-] Error received from [ovsdb-client monitor Interface name,ofport,external_ids --format=json]: None
2017-06-22 21:06:32.630 30776 ERROR neutron.agent.linux.async_process [-] Process [ovsdb-client monitor Interface name,ofport,external_ids --format=json] dies due to the error: None 

ERROR neutron.plugins.ml2.managers [req-ba927280-1b89-4266-a3e2-b4f13ce68236 a6a62cffdee14d4c86c24ca0c3e1796f eedcf4e363f841218d822c88347abc06 - - -] Failed to bind port 8056eb45-1122-4ba6-86ed-223f45c0109c on host Controller1 for vnic_type normal using segments [{'segmentation_id': None, 'physical_network': u'default', 'id': u'8a638929-c31f-4d59-8c50-e33fa503b7c4', 'network_type': u'flat'}]

my /etc/default/neutron-server file says:

NEUTRON_PLUGIN_CONFIG="/etc/neutron/plugins/ml2/openvswitch_agent.ini"

In /etc/neutron i have a soft link:

plugin.ini -> /etc/neutron/plugins/ml2/openvswitch_agent.ini

openvswitch_agent.ini is as follows:

[DEFAULT]

#
# From oslo.log
#

# If set to true, the logging level will be set to DEBUG instead of the default
# INFO level. (boolean value)
# Note: This option can be changed without restarting.
#debug = false

# DEPRECATED: If set to false, the logging level will be set to WARNING instead
# of the default INFO level. (boolean value)
# This option is deprecated for removal.
# Its value may be silently ignored in the future.
#verbose = true

# The name of a logging configuration file. This file is appended to any
# existing logging configuration files. For details about logging configuration
# files, see the Python logging module documentation. Note that when logging
# configuration files are used then all logging configuration is set in the
# configuration file and other logging configuration options are ignored (for
# example, logging_context_format_string). (string value)
# Note: This option can be changed without restarting.
# Deprecated group/name - [DEFAULT]/log_config
#log_config_append = <None>

# Defines the format string for %%(asctime)s in log records. Default:
# %(default)s . This option is ignored if log_config_append is set. (string
# value)
#log_date_format = %Y-%m-%d %H:%M:%S

# (Optional) Name of log file to send logging output to. If no default is set,
# logging will go to stderr as defined by use_stderr. This option is ignored if
# log_config_append is set. (string value)
# Deprecated group/name - [DEFAULT]/logfile
#log_file = <None>

# (Optional) The base directory used for relative log_file  paths. This option
# is ignored if log_config_append is set. (string value)
# Deprecated group/name - [DEFAULT]/logdir
#log_dir = <None>

# Uses logging handler designed to watch file system. When log file is moved or
# removed this handler will open a new log file with specified path
# instantaneously. It makes sense only if log_file option is specified and
# Linux platform is used. This option is ignored if log_config_append is set.
# (boolean value)
#watch_log_file = false

# Use syslog for logging. Existing syslog format is DEPRECATED and will be
# changed later to honor RFC5424. This option is ignored if log_config_append
# is ...
(more)
edit retag flag offensive close merge delete

Comments

I have a Liberty all-in-one cloud and find the ovsdb-client message several times in the openvswitch log file. My first thought is that this message is harmless.

See if you find other messages related to the port 8056eb45-1122-4ba6-86ed-223f45c0109c in the Neutron logs.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-24 01:17:52 -0500 )edit
1

Other comments: I see 'physical_network': u'default', but the only physical network in the ini file is named physnet2. Also, you are trying to bind the port to a flat network; is that your intention? Can you display the details of the provider network e.g. openstack network show public?

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-24 01:29:41 -0500 )edit

Thanks Bernd Bausch for the comments. Yes i want to create flat network and map it to physnet2. Here is the output you requested: [root@Controller1 ~(keystone_admin)]# openstack network show public ResourceNotFound: No Network found for public I have shared=TRUE in existing external network.

Lucky gravatar imageLucky ( 2017-06-26 06:07:38 -0500 )edit

I said public because that is the default name of the external network when you use Packstack. What I (and you) want to know is the details of the external network. Also, to which network do you connect the VM? There is a misconfig somewhere, "default" vs. "physnet2".

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-26 06:11:16 -0500 )edit

Perhaps you can also share your answer file on paste.openstack.org.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-26 06:12:54 -0500 )edit