Ask Your Question
1

OpenSource Mano (OSM) & OpenStack: “The request you have made requires authentication. (HTTP 401)”

asked 2017-06-22 09:20:17 -0500

Wintermute gravatar image

updated 2018-05-24 12:50:08 -0500

Hello,

Currently working on Newtorks Virtualization, I am trying to configure OpenStack and Open Source MANO to make them work together. I am following the OSM tutorial (https://osm.etsi.org/wikipub/index.ph...). I have a problem at the step "Instantiating a NS". After clicking on Launch, I’ve got the following message:

VIM Exception vimconnUnexpectedResponse Unauthorized: The request you have made requires authentication.
(HTTP 401) (Request-ID: req-83c01de4-4942-414c-8431-73ee089dd1b6). 
(False, " Rollback fails to delete: ['network TASK.1498137381.233714 from VIM openstack-site2']")

I don't understand where it is coming from. When I am trying to connect in a browser to the address I put when creating the datacenter (10.0.3.44:8447/v2.1), I get the same HTTP 401 error. This address is the one I found in the "API Access" section of the OpenStack UI for the compute service. I used it to create the datacenter in openmano:

openmano datacenter-create openstack-site http://10.0.3.44:8447/v2.1 --type openstack --description "OpenStack site"
openmano datacenter-attach openstack-site --user=admin --password=mypwd --vim-tenant-name=admin

Does anyone know what could be my problem?

Thank you.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2017-06-28 09:45:47 -0500

Wintermute gravatar image

I resolved my problem thanks to the technical support of OSM. The problem came from the adress I was using. If you encounter the same problem, try to use the address:

http://<openstack machine IP>/identity/v2.0

By example, in my case, I used the commands:

openmano datacenter-create openstack-site http://10.0.3.44/identity/v2.0 --type openstack --description "OpenStack site"
openmano datacenter-attach openstack-site --user=admin --password=mypwd --vim-tenant-name=admin
edit flag offensive delete link more
0

answered 2018-05-23 11:32:27 -0500

p4pe gravatar image

Hello, currently I start to work on Networks Virtualization. And I'm trying to integrate Openstack with OSM.

I installed OSM in a VM inside VMWare and also I have 3 VMS for Openstack (2 compute 1 controller), all VMs are in the same cluster.

I saw wiki page of OSM and I use the osm vim-create command. It seems tha it works cause with osm vim-list command I saw the uuid and the name.

When I tried to instantiate vnfs I had an error

Instantiation of NS 3b685a20-21b9-4a9e-8e03-41e02c84d774 - test failed VIM Exception vimconnConnectionException ConnectFailure: Unable to establish connection to http://controller.dai.uom.gr:5000/v3/auth/tokens (http://controller.dai.uom.gr:5000/v3/...): HTTPConnectionPool(host='controller.dai.uom.gr', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7f54a53f0b10="" at="" object="">: Failed to establish a new connection: [Errno 113] No route to host',)). (True, ' Rollback successful.')</urllib3.connection.httpconnection>

edit flag offensive delete link more

Comments

It doesn’t make much sense to ask your question as an answer to a different question that was solved one year ago. Create a new question instead.

Bernd Bausch gravatar imageBernd Bausch ( 2018-05-23 18:41:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-06-22 09:20:17 -0500

Seen: 1,026 times

Last updated: May 24 '18