Cannot login to dashboard because of Using signed cookies as SESSION_ENGINE with OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT is enabled. This disables the ability to perform identity operations due to cookie size constraints

asked 2017-06-20 18:21:35 -0600

ben_hall gravatar image

When I attempt to login to the dashboard, I get the error message "Using signed cookies as SESSION_ENGINE with OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT is enabled. This disables the ability to perform identity operations due to cookie size constraints".

Openstack is deployed via DevStack and I can login via the CLI. I've tried setting OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT to true/false in /opt/stack/horizon/openstack_dashboard/local/local_settings.py but that doesn't seem to change the response.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-08-31 00:51:58 -0600

Jeffrey Guan gravatar image

updated 2017-08-31 01:01:12 -0600

I met the same issue after installation of devstack stable/pike.

The error is as follows:

319 2017-08-31 05:19:08.849717 ERROR

openstack_auth.backend Using signed cookies as SESSION_ENGINE with OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT is enabled

. This disables the ability to perform identity operations due to cookie size constraints.

Here comes the solution:

Step 1

update the following code in /opt/stack/horizon/openstack_dashboard/settings.py

> 196 # jeffrey guan
> 
> 197 #SESSION_ENGINE =
> 'django.contrib.sessions.backends.signed_cookies'
> 
> 198 SESSION_ENGINE =
> 'django.contrib.sessions.backends.cache'
> 
> 199 # jeffrey guan

Step 2

Make changes in /opt/stack/horizon/openstack_dashboard/local/local_settings.py

>  71 # jeffrey guan
> 
>  72 OPENSTACK_API_VERSIONS = {
> 
>  73     "data-processing": 1.1,
> 
>  74     "identity": 3,
> 
>  75     "image": 2,
> 
>  76     "volume": 2,
> 
>  77     "compute": 2,
> 
>  78 }
> 
>  79  
> 
>  80 # jeffrey guan

     81 # Set this to True if running on a multi-domain model. When this is enabled, it

     82 # will require the user to enter the Domain name in addition to the username

     83 # for login.

     84 #OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT
= False

>  85 # jeffrey guan
> 
>  86
> OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT
> = True
> 
>  87 # jeffrey guan
enter code here
162 # jeffrey guan

163 # We recommend you use memcached for development; otherwise after every reload

164 # of the django development server, you will have to login again. To use

165 # memcached set CACHES to something like

166 CACHES = {

167 'default': {

168 'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',

169 'LOCATION': '127.0.0.1:11211',

170 },

171

172 }

173

174 #CACHES = {

175 # 'default': {

176 # 'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',

177 # },

178 #}

179 # jeffrey guan

> 

> 510 POLICY_FILES = {
> 
> 511     'identity':
> 'keystone_policy.json',
> 
> 512     'compute': 'nova_policy.json',
> 
> 513     'volume':
> 'cinder_policy.json',
> 
> 514     'image': 'glance_policy.json',
> 
> 515     'orchestration':
> 'heat_policy.json',
> 
> 516     'network':
> 'neutron_policy.json',
> 
> 517 }
> 
> 518 # jeffrey guan

Step 3

cp /opt/stack/horizon/openstack_dashboard/conf/keystone_policy.json /etc/openstack-dashboard/keystone_policy.json

Step 4

systemctl restart apache2.service

REF:

https://docs.openstack.org/security-g...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-06-20 18:21:35 -0600

Seen: 764 times

Last updated: Aug 31 '17