Unable to list extension for network

asked 2017-06-20 14:49:42 -0600

Asghar0819 gravatar image

I am following Install Guide 15.0.0 to install OpenStack stack environment. https://docs.openstack.org/ocata/install-guide-ubuntu/InstallGuide.pdf (https://docs.openstack.org/ocata/inst...)

After completing network services configuration using Network Options 2 Provider network, I am getting an error when using the command below for listing extensions for network services. The error indicates that the auth_url is missing. I have followed installation guide to the word, but cannot figure out where is the auth-url missing value needs to be added. Your suggestions are greatly appreciated.

root@Controller-1:/var/log/neutron# openstack extension list --network Missing value auth-url required for auth plugin password

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2017-06-21 02:26:22 -0600

updated 2017-06-21 02:26:40 -0600

The auth URL is normally stored in a shell variable OS_AUTH_URL, whose value you set by sourcing a script as explained in the tutorial. In addition to the authentication URL, you need other pieces of information like user name, project name and password - all set via the script.

edit flag offensive delete link more

answered 2017-06-21 16:04:28 -0600

Asghar0819 gravatar image

Thanks! If have another issue which I will ask in a separate questionl

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-06-20 14:49:42 -0600

Seen: 951 times

Last updated: Jun 21 '17