Ask Your Question
0

MAAS Failed commisoning

asked 2017-06-20 07:29:23 -0500

TijoV gravatar image

We are using 2 Networks for Openstack deployment in a setup where we have 1 Maas Node, 2 Controller nodes and 3 Hypervisors nodes. On Maas GUI under subnets, for Private network (PXE boot network) if we keep its default Gateway, MAAS servers is not able to Commission the Controller or Hypervisor nodes. But, if we keep the MAAS servers Private network IP as Default Gateway for the Private networkwe are able to Commision every nodes. And we can begin with Openstack Deploment. but after Openstack deployment we are seeing MAAS servers Private network IP as the Default Gateway on every commmissioned nodes, which is causing issues. Can someone help, I presume there need some IP rules need to be added on Ubuntu 16.04 MAAS server, but am not sure what it is.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-06-20 10:58:48 -0500

Use the the link https://docs.ubuntu.com/maas/2.1/en/troubleshoot-faq (https://docs.ubuntu.com/maas/2.1/en/t...) hope this will help.

edit flag offensive delete link more
0

answered 2017-07-19 05:54:35 -0500

TijoV gravatar image

updated 2017-07-19 05:57:27 -0500

Ok, What I have done to fix is on my MAAS node (version 2.2) run the below command, sudo dpkg-reconfigure maas-region-controller sudo dpkg-reconfigure maas-rack-controller

and changed every IP we saw as the MAAS node Private IP.

After that its fixed for me and worked well. I was able to commission all node well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-20 07:29:23 -0500

Seen: 456 times

Last updated: Jul 19 '17

Related questions