Ask Your Question
0

something went wrong after click ok instances

asked 2017-06-20 02:35:47 -0500

chtsalid gravatar image

updated 2017-06-20 07:20:29 -0500

Hi all,

I run openstack mitaka on CentOS 7 and get the following error afer I click on instances logged in as a user.

Something went wrong!

Any idea where the problem lies?

[root@servera ~(keystone_admin)]# openstack-status |grep nova
openstack-nova-api:                     active
openstack-nova-compute:                 active
openstack-nova-network:                 inactive  (disabled on boot)
openstack-nova-scheduler:               active
openstack-nova-cert:                    active
openstack-nova-conductor:               active
openstack-nova-console:                 inactive  (disabled on boot)
openstack-nova-consoleauth:             active
openstack-nova-xvpvncproxy:             inactive  (disabled on boot)
| bf765181d0bb43e3b34e019bf9a4b710 | nova       |
Error finding address for http://192.168.178.101:9292/versions: Unable to establish connection to http://192.168.178.101:9292/versions
| 3  | nova-cert        | servera.lab.local | internal | enabled | up    | 2017-06-20T06:32:51.000000 | -               |
| 4  | nova-consoleauth | servera.lab.local | internal | enabled | up    | 2017-06-20T06:32:51.000000 | -               |
| 5  | nova-scheduler   | servera.lab.local | internal | enabled | up    | 2017-06-20T06:32:51.000000 | -               |
| 6  | nova-conductor   | servera.lab.local | internal | enabled | up    | 2017-06-20T06:32:51.000000 | -               |
| 7  | nova-compute     | servera.lab.local | nova     | enabled | up    | 2017-06-20T06:32:51.000000 | -  

[root@servera ~(keystone_admin)]# openstack-status |grep neutron
== neutron services ==
neutron-server:                         active
neutron-dhcp-agent:                     active
neutron-l3-agent:                       active
neutron-metadata-agent:                 active
neutron-lbaas-agent:                    active
neutron-lbaasv2-agent:                  inactive  (disabled on boot)
neutron-openvswitch-agent:              active
neutron-metering-agent:                 active
| ab355d69468342b9a04b5f8426b64bdb | neutron    |
Error finding address for http://192.168.178.101:9292/versions: Unable to establish connection to http://192.168.178.101:9292/versions

Many thanks!

edit retag flag offensive close merge delete

Comments

9292 is glance api port, ensure glance api is up and running fine and the endpoints point to the right url

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-06-20 07:26:03 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-20 07:27:56 -0500

I don't know what you mean by "click on instances logged in as a user", but the message Unable to establish connection to http://192.168.178.101:9292/versions could mean that Glance isn't running, or that port 9292 on that server isn't accessible for other reasons, or that the catalog contains a wrong endpoint for Glance.

Therefore, as a first step I would check if:

  • address 192.168.178.101 is correct
  • glance-api is listening at port 9292 at that address
  • that port is not blocked
  • Glance endpoints are configured correctly (openstack catalog list)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-20 02:35:47 -0500

Seen: 47 times

Last updated: Jun 20 '17