Am I missing a configuration option for Magnum? Error "no such option B in group [DEFAULT]"

asked 2017-06-19 12:26:25 -0500

insecure-it gravatar image

updated 2017-06-19 12:35:56 -0500

I'm using Redhat 7.3, RDO ocata. I've been following the install guide (https://docs.openstack.org/project-install-guide/container-infrastructure-management/ocata/install-rdo.html (https://docs.openstack.org/project-in...)).

When I run su -s /bin/sh -c "magnum-db-manage version" magnum I get the following error:

su -s /bin/sh -c "magnum-db-manage version" magnum

Traceback (most recent call last):
  File "/bin/magnum-db-manage", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/magnum/cmd/db_manage.py", line 69, in main
    CONF.command.func()
  File "/usr/lib/python2.7/site-packages/magnum/cmd/db_manage.py", line 25, in do_version
    print('Current DB revision is %s' % migration.version())
  File "/usr/lib/python2.7/site-packages/magnum/db/migration.py", line 41, in version
    return get_backend().version()
  File "/usr/lib/python2.7/site-packages/magnum/db/sqlalchemy/migration.py", line 48, in version
    return get_manager().version()
  File "/usr/lib/python2.7/site-packages/magnum/db/sqlalchemy/migration.py", line 36, in get_manager
    'db_url': CONF.database.connection}
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 3198, in __getattr__
    return self._conf._get(name, self._group)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2790, in _get
    value = self._do_get(name, group, namespace)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2827, in _do_get
    return convert(opt._get_from_namespace(namespace, group_name))
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2818, in convert
    self._substitute(value, group, namespace), opt)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2875, in _substitute
    self.StrSubWrapper(self, group=group, namespace=namespace))
  File "/usr/lib64/python2.7/string.py", line 205, in safe_substitute
    return self.pattern.sub(convert, self.template)
  File "/usr/lib64/python2.7/string.py", line 190, in convert
    return '%s' % (mapping[named],)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 3287, in __getitem__
    value = self.conf._get(key, namespace=self.namespace)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2790, in _get
    value = self._do_get(name, group, namespace)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2807, in _do_get
    info = self._get_opt_info(name, group)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2946, in _get_opt_info
    raise NoSuchOptError(opt_name, group)
oslo_config.cfg.NoSuchOptError: no such option B in group [DEFAULT]

Version Info:

[root@controller00 ~]# magnum-api --version
4.1.0

[root@controller00 ~]# magnum --version
2.5.0

[root@controller00 ~]# magnum-conductor --version
4.1.0

[root@controller00 ~]# magnum-driver-manage   --version
magnum-driver-manage 4.1.0

Configuration at /etc/magnum/magnum.conf:

[DEFAULT]
transport_url = rabbit://username:password@host:5671
[api]
host = ip_addr
enabled_ssl = True
cert_file = /etc/pki/tls/certs/host.crt
key_file = /etc/pki/tls/private/host.key
[barbican_client]
[certificates]
cert_manager_type = local
storage_path = /var/lib/magnum/certificates/
[cinder_client]
region_name = RegionOne
[cluster]
[cluster_heat]
[cluster_template]
[conductor]
[cors]
[cors.subdomain]
[database]
connection = postgresql://user:"p@ssw0rd"@host/osmagnum_db
[docker]
[docker_registry]
[glance_client]
[heat_client]
[keystone_auth]
[keystone_authtoken]
memcached_servers = host:11211
auth_version = v3
auth_uri = https://host:5000/v3
project_domain_id = Default
project_name = service
user_domain_id = Default
password = password
username = magnum
auth_url = https://host:35357
auth_type = password
[magnum_client]
[matchmaker_redis ...
(more)
edit retag flag offensive close merge delete