Ask Your Question
0

Quick question about pinging a router

asked 2017-06-18 20:53:31 -0500

tiger gravatar image

Hello,

Suppose I just ran packstack. I create a router. I create an external network. I add the external interface to the router. The router then gets assigned an IP address on the external network. The external network was created as "flat". From the controller node I cannot ping the address. I have been able to in the past. I don't know what I did differently this time. Thank you in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-27 09:51:41 -0500

tiger gravatar image

Thanks for all the replies. In case anyone wants to know how I fixed it, make sure "extnet" is in the "physical network" field that appears after you select "flat" in the field above it. By default, it will be "local" and the "physical network" field will be missing. After you select "flat" and the "physical network" appears, it will have "default" in it. Change that to "extnet" which needs to have been mentioned in the "answers" file:

CONFIG_NEUTRON_OVS_EXTERNAL_PHYSNET=extnet CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=extnet:br-ex

In retrospect I suppose I should have guessed this. Would be wonderful if the documentation were useful. I have an idea! How about an OpenStack "cookbook" with basic recipes for setting this shit up?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-18 20:53:31 -0500

Seen: 104 times

Last updated: Jul 27 '17