Problem selecting Nova version using juju

asked 2017-06-14 13:49:09 -0600

I am using Cannonical Openstack Newton with Ubuntu 16.04.

I need to force Nova version to 14.0.4.

I have tried through the juju options of the nova-cloud-controller. Unable to choose Nova version 14.0.4 through openstack-origin-git option in the juju bundle:

...
  openstack-origin-git: |
        repositories:
        - {name: requirements,
          repository: 'git://github.com/openstack/requirements',
          branch: stable/newton}
        - {name: neutron,
          repository: 'git://github.com/openstack/neutron',
          branch: stable/newton}
        - {name: nova,
          repository: 'git://github.com/openstack/nova',
          branch: stable/newton}
        release: 14.0.4
...

Status of the unit: blocked - Services not running that should be: nova-api-ec2, nova-objectstore

In the /var/log/juju/unit-nova-cloud-controller-0.log apparently everithing went well.

edit retag flag offensive close merge delete