Openstack Aodh doesn't start on 8042

asked 2017-06-13 15:41:01 -0600

Newbie_OS gravatar image

Hi All,

I am installing openstack Aodh Service and when I ran aodh-api, it starts by default on port 8000 not on 8042 and when I do aodh-api -p 8042 it says:

```usage: aodh-api [-h] [--config-dir DIR] [--config-file PATH] [--debug] [--log-config-append PATH] [--log-date-format DATE_FORMAT] [--log-dir LOG_DIR] [--log-file PATH] [--nodebug] [--nouse-syslog] [--noverbose] [--nowatch-log-file] [--syslog-log-facility SYSLOG_LOG_FACILITY] [--use-syslog] [--verbose] [--watch-log-file]

aodh-api: error: unrecognized arguments: -p 8042```

and when I do aodh-api --config-file /etc/aodh/aodh.conf, I get this:

usage: aodh-api [-h] [--port PORT] aodh-api: error: unrecognized arguments: --config-file /etc/aodh/aodh.conf

edit retag flag offensive close merge delete

Comments

From https://docs.openstack.org/developer/...: Try

aodh-api --port 8042 -- --config-file /etc/aodh/aodh.conf
Bernd Bausch gravatar imageBernd Bausch ( 2017-06-14 00:46:33 -0600 )edit

Thanks for reply, I tried this too, got the same error: usage: aodh-api [-h] [--port PORT] aodh-api: error: unrecognized arguments: --config-file /etc/aodh/aodh.conf

Newbie_OS gravatar imageNewbie_OS ( 2017-06-14 03:04:44 -0600 )edit

What version of Aodh did you install?

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-14 05:44:59 -0600 )edit

I have installed stable/ocata. So default version will be there I guess

Newbie_OS gravatar imageNewbie_OS ( 2017-06-14 05:52:29 -0600 )edit