Ask Your Question
0

the openstack install guide says that the provider network needs an ip but then uses a special config without an ip

asked 2017-06-13 06:43:30 -0500

logax gravatar image

Hello, Can any one please tell me why the openstack guide says that we need to configure a second interface using this as an example : Provider on 203.0.113.0/24 with gateway 203.0.113.1

           This network requires a gateway to provide Internet access to instances in your OpenStack environment.

but then in the next page they tell you to :

"The provider interface uses a special configuration without an IP address assigned to it. Configure the second interface as the provider interface:

Replace INTERFACE_NAME with the actual interface name. For example, eth1 or ens224.

Edit the /etc/network/interfaces file to contain the following:

The provider network interface

auto INTERFACE_NAME iface INTERFACE_NAME inet manual up ip link set dev $IFACE up down ip link set dev $IFACE down "

How to do this ?? plz help

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-13 07:13:12 -0500

updated 2017-06-13 07:17:47 -0500

In this case, the routing for 203.0.113.0/24 is done by an external router ( yours or your providers ) via gw 203.0.113.1

So the 203.0.113.1 is not inside your OS environment. When you configure the provider net, you tell neutron about the subnet and the gw address ( some more parameters are possible, like vlan id ..) . When you setup a router inside your OS env, you need to add a gateway, which will be located inside the provider net. This router then will receive a public IP from inside this net ( e.g. 203.0.113.2 ). If everything is correct, you will be able to ping that ip. The router's IP exists inside a so called namespace. You can inspect the namespaces with the command ip netns. You may see something like

qrouter-a2da1577-b986-4af9-bbd6-9718f6294920 With " ip netns exec qrouter-a2da1577-b986-4af9-bbd6-9718f6294920 ip a you will then be able see the routers Gateway IP.

Physically the interface only needs to be set as manually up. that's why:

iface INTERFACE_NAME inet manual
ip link set dev $IFACE up

edit flag offensive delete link more

Comments

thank you for replying, Can you please be more clear on what exactly i should do ?? i already setup the OS environement with the automatic ip adresses, so now, regarding the 203.0.113.0/24 i do not understand what exactly i should do about it ... ??

i'm a noob here and this for a project .

logax gravatar imagelogax ( 2017-06-13 07:30:07 -0500 )edit

I'll have a try: You want to provide external addresses for your instances. So you need too have an interface, connected to the internet, let's say it's name is eth0.

auto eth0
iface eth0 inet manual
        up ip link set dev $IFACE up
        down ip link set dev $IFACE down
Frank_SU_HH gravatar imageFrank_SU_HH ( 2017-06-14 02:34:19 -0500 )edit

No static or dynamic IP, nothing. The gateway ( as for the example 203.0.113.1 ) is located on any router of your uplink provider (company, networking department, whatever ) You set

[linux_bridge]
physical_interface_mappings = eth0

inside /etc/neutron/plugins/ml2/linuxbridge_agent.ini

Frank_SU_HH gravatar imageFrank_SU_HH ( 2017-06-14 02:38:21 -0500 )edit

The address range and gateway IP will be needed, when you define the subnet for the external network.That's it

Frank_SU_HH gravatar imageFrank_SU_HH ( 2017-06-14 02:43:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-06-13 06:43:30 -0500

Seen: 33 times

Last updated: Jun 13