Ask Your Question
0

IP not been configured in VM os, but openstanck assign IP for it

asked 2017-06-11 18:16:22 -0500

xiaotie gravatar image

updated 2017-06-12 00:34:04 -0500

I lanch an instance, but the instance has not IP when I run command 'ip addr'.But router has assign ip for it.

My environment is: two vms in virtualbox each vm has two ethernet, 192.168.5.0/24 use bridge network; 10.0.0.0/24 use nat network, both is ok I lanch provider network, and router ip is 192.168.5.203, I can ping it on the host. openstack instance has got an ip,192.168.5.205, I can see it in network top0loy of the dashboard, and I can see provider network port is up,but I can't ping it.

Router info

+--------------------------------------+--------+----------------------------------+-----------------------------------------+-------------+-------+
  | id                                   | name   | tenant_id                        | external_gateway_info                   | distributed | ha    |
  +--------------------------------------+--------+----------------------------------+-----------------------------------------+-------------+-------+
  | efdc40ab-9425-4795-949e-6774eabceed0 | router | dfeb844b4942417e9e2d1299c49d1a3a | {"network_id":                          | False       | False |
  |                                      |        |                                  | "1807f022-b989-4725-9d25-7d176b28ec72", |             |       |
  |                                      |        |                                  | "enable_snat": true,                    |             |       |
  |                                      |        |                                  | "external_fixed_ips": [{"subnet_id":    |             |       |
  |                                      |        |                                  | "59fc76f2-c666-4693-b0f6-2a96a0189ef7", |             |       |
  |                                      |        |                                  | "ip_address": "192.168.5.203"}]}        |             |       |
  +--------------------------------------+--------+----------------------------------+-----------------------------------------+-------------+-------+

Port status

  名称    固定IP    连接设备    状态  管理状态    动作
  (85f154ee-1dd6)   192.168.5.205 compute:None  运行中     UP

when i lanch an instance, I got the following error on the compute node:

  2017-06-12 06:49:43.610 20776 INFO neutron.agent.securitygroups_rpc [req-4fcd8220-8713-469c-9564-1d1eebf30675 472ca430fc46406abac12d2bb877326f dfeb844b4942417e9e2d1299c49d1a3a - - -] Security group member updated [u'b7da029d-70f0-4ac2-af09-fea4d0e8e516']
  2017-06-12 06:49:45.354 20776 INFO neutron.agent.securitygroups_rpc [req-bfc74178-179f-4abd-bdb2-25d66ce36107 - - - - -] Refresh firewall rules
  2017-06-12 06:49:47.358 20776 INFO neutron.agent.securitygroups_rpc [req-bfc74178-179f-4abd-bdb2-25d66ce36107 - - - - -] Preparing filters for devices set(['tap9db05558-8e'])
  2017-06-12 06:49:49.273 20776 INFO neutron.plugins.ml2.drivers.agent._common_agent [req-bfc74178-179f-4abd-bdb2-25d66ce36107 - - - - -] Port tap9db05558-8e updated. Details: {u'profile': {}, u'network_qos_policy_id': None, u'qos_policy_id': None, u'allowed_address_pairs': [], u'admin_state_up': True, u'network_id': u'1807f022-b989-4725-9d25-7d176b28ec72', u'segmentation_id': None, u'device_owner': u'compute:nova', u'physical_network': u'provider', u'mac_address': u'fa:16:3e:61:90:f5', u'device': u'tap9db05558-8e', u'port_security_enabled': True, u'port_id': u'9db05558-8e87-4a24-928c-cd97ddddb777', u'fixed_ips': [{u'subnet_id': u'59fc76f2-c666-4693-b0f6-2a96a0189ef7', u'ip_address': u'192.168.5.211'}], u'network_type': u'flat'}
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager [req-bfc74178-179f-4abd-bdb2-25d66ce36107 - - - - -] Error during notification for neutron.services.trunk.drivers.linuxbridge.agent.driver.LinuxBridgeTrunkDriver.agent_port_change--9223372036853960796 port_device, after_update
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager Traceback (most recent call last):
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager   File "/usr/lib/python2.7/site-packages/neutron/callbacks/manager.py", line 146, in _notify_loop
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager     callback(resource, event, trigger, **kwargs)
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager   File "/usr/lib/python2.7/site-packages/neutron/services/trunk/drivers/linuxbridge/agent/driver.py", line 94, in agent_port_change
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager     trunk = self._tapi.get_trunk(context, device_details['port_id'])
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager   File "/usr/lib/python2.7/site-packages/neutron/services/trunk/drivers/linuxbridge/agent/driver.py", line 196, in get_trunk
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager     self.put_trunk(port_id, self._fetch_trunk(context, port_id))
  2017-06-12 06:49:50.591 20776 ERROR neutron.callbacks.manager   File "/usr/lib/python2.7/site-packages/neutron/services/trunk/drivers/linuxbridge/agent/driver.py", line 140, in _fetch_trunk
  2017-06-12 06:49:50 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-06-12 07:44:34 -0500

Hi, the errors indicate a python error, not an Openstack error. 'ascii' codec can't encode characters in position 31-35: ordinal not in range(128)

As the python code inside of the openstack modules is working usually, maybe your locales are missing something?

greetings

Frank

edit flag offensive delete link more

Comments

Thanks, this is a code bug, and openstack develper team has fix it. Thank you

xiaotie gravatar imagexiaotie ( 2017-06-15 21:29:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-06-11 18:16:22 -0500

Seen: 38 times

Last updated: Jun 12 '17