Can't login to dashboard [closed]

asked 2017-06-08 23:29:37 -0500

badgerdog gravatar image

updated 2017-06-12 09:12:21 -0500

rbowen gravatar image

Still learning Openstack; I have installed Openstack following the "https://docs.openstack.org/ocata/install-guide-rdo/index.html" I'm installed the controller, compute and storage node on CentOS7. Everything appears to work fine as long as I use the CLI, but I'm unable to login dashboard. I do get the web login, but the web throws "Invalid credentials" error. I've enabled debug int eh /etc/openstack-dashboard/local_settings file and then monitored my httpd/error_log. The error_log shows the following:

[Fri Jun 09 04:07:57.234421 2017] [:error] [pid 3248] DEBUG:keystoneauth.identity.v3.base:Making authentication request to http://controller:5000/v3.0/auth/tokens
[Fri Jun 09 04:07:58.721357 2017] [:error] [pid 3248] DEBUG:keystoneauth.session:Request returned failure status: 404
[Fri Jun 09 04:07:58.721657 2017] [:error] [pid 3248] Login failed for user "admin", remote address 192.168.0.200.

I get the same error whenever I try to login with the demo user as well. Would like to know how to troubleshoot this problem.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by mary_grace
close date 2018-01-26 20:02:18.241519

Comments

badgerdog - is this still an unresolved issue? if so, please add a comment with the other solutions you've tried and any current logs.

mary_grace gravatar imagemary_grace ( 2017-12-14 17:52:38 -0500 )edit