Ask Your Question
1

dhcp issue

asked 2014-01-21 02:04:16 -0500

ygk gravatar image

Hi,

I have installed openstack on ubuntu. Its a three node setup. While launching the instance, its not getting the IP from DHCP. It is sending discover and failing. Do we need to add any rule in iptables or disable apparmor in ubuntu ?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-01-21 06:48:46 -0500

RomilGupta gravatar image

Can you please let us know which plugin(ovs or linuxbridge or ml2 ) and network_type( vlan or vxlan) you are using ? If it is openvswitch check the flows is created on NN and CN node just by executing the following command :

ovs-ofctl dump-flows br-int
edit flag offensive delete link more

Comments

Its a ovs plugin. And I configured GRE.

ygk gravatar imageygk ( 2014-01-21 11:21:52 -0500 )edit

then.....try to see the tunnel based flows on br-tun.

RomilGupta gravatar imageRomilGupta ( 2014-01-22 11:26:28 -0500 )edit

I followed the installation guide for ubuntu. Is the guide lacking some info ? So, what should I first check in my three-node setup ?

ygk gravatar imageygk ( 2014-01-23 07:37:30 -0500 )edit

These are the results of the command : ------ Compute node -------------- root@compute:/home/oss# ovs-ofctl dump-flows br-int NXST_FLOW reply (xid=0x4): cookie=0x0, duration=254815.638s, table=0, n_packets=77, n_bytes=11870, idle_age=65534, hard_age=65534, priority=1 actions=NORMAL root@compute:/home/oss#

ygk gravatar imageygk ( 2014-01-23 23:00:26 -0500 )edit

on Neutron node --------------------- root@neutron:/home/oss# ovs-ofctl dump-flows br-int NXST_FLOW reply (xid=0x4): cookie=0x0, duration=254120.253s, table=0, n_packets=45, n_bytes=3606, idle_age=65534, hard_age=65534, priority=1 actions=NORMAL

ygk gravatar imageygk ( 2014-01-23 23:00:54 -0500 )edit
0

answered 2014-01-22 05:06:21 -0500

anemic gravatar image

try to tcpdump your raw interface to see the traffic. Sometimes the GRE tunnel just goes one-way, the DHCP request goes in the GRE tunnel but the reply is sent without GRE.

But I can't help how to fix that permanently, for me restarting neutron-server,neutron-plugin-openvswitch-agent and openvswitch-switch usually works.

edit flag offensive delete link more

Comments

I followed the installation guide for ubuntu. Is the guide lacking some info ? So, what should I first check in my three-node setup ?

ygk gravatar imageygk ( 2014-01-23 07:36:46 -0500 )edit
0

answered 2014-01-24 02:50:49 -0500

ygk gravatar image

Hi All,

I am still not able to figure it out. On compute node , I see the followin interfaces.

root@compute:/home/oss# ifconfig br-int Link encap:Ethernet HWaddr 56:19:99:6a:48:45 inet6 addr: fe80::4c06:a6ff:fe75:9314/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:6 errors:0 dropped:0 overruns:0 frame:0 TX packets:6 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:468 (468.0 B) TX bytes:468 (468.0 B)

br-tun Link encap:Ethernet HWaddr 3a:0f:5f:fd:c0:48 inet6 addr: fe80::4:f7ff:fe89:9260/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:5 errors:0 dropped:0 overruns:0 frame:0 TX packets:6 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:378 (378.0 B) TX bytes:468 (468.0 B)

eth0 Link encap:Ethernet HWaddr 00:50:56:ab:19:b8 inet addr:10.211.203.126 Bcast:10.211.203.255 Mask:255.255.255.0 inet6 addr: fe80::250:56ff:feab:19b8/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1023 errors:0 dropped:18 overruns:0 frame:0 TX packets:242 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:101658 (101.6 KB) TX bytes:25477 (25.4 KB)

eth1 Link encap:Ethernet HWaddr 00:50:56:ab:19:b9 inet addr:192.168.1.126 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::250:56ff:feab:19b9/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:922 errors:0 dropped:20 overruns:0 frame:0 TX packets:32 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:87821 (87.8 KB) TX bytes:2538 (2.5 KB)

eth2 Link encap:Ethernet HWaddr 00:50:56:ab:19:ba inet addr:10.0.0.126 Bcast:10.0.0.255 Mask:255.255.255.0 inet6 addr: fe80::250:56ff:feab:19ba/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:898 errors:0 dropped:19 overruns:0 frame:0 TX packets:6 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:85871 (85.8 KB) TX bytes:468 (468.0 B)

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

virbr0 Link encap:Ethernet HWaddr ee:60:8f:06:de:bc inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-21 02:04:16 -0500

Seen: 149 times

Last updated: Jan 24 '14