How can I enable compute metrics?

asked 2017-06-08 14:20:19 -0500

mkhan gravatar image

updated 2017-06-13 02:45:50 -0500

My current environment is on Mitaka. Attached files are nova.conf on compute node and metrics ar shown. The missing metrics are Volume, Memory, memory.used.

[root@Mitaka-KVM1 ~]# grep -v \# /etc/nova/nova.conf | grep -v ^$
[DEFAULT]
notify_api_faults=False
state_path=/var/lib/nova
report_interval=10
compute_manager=nova.compute.manager.ComputeManager
service_down_time=60
rootwrap_config=/etc/nova/rootwrap.conf
volume_api_class=nova.volume.cinder.API
auth_strategy=keystone
heal_instance_info_cache_interval=60
compute_monitors = cpu.virt_driver
reserved_host_memory_mb=512
allow_resize_to_same_host=False
compute_driver=libvirt.LibvirtDriver
vif_plugging_is_fatal=True
vif_plugging_timeout=300
firewall_driver=nova.virt.firewall.NoopFirewallDriver
force_raw_images=True
use_neutron=True
force_snat_range =0.0.0.0/0
metadata_host=10.10.150.191
dhcp_domain=novalocal
security_group_api=neutron
debug=False
verbose=True
log_dir=/var/log/nova
rpc_backend=rabbit
notification_driver=nova.openstack.common.notifier.rabbit_notifier,ceilometer.compute.nova_notifier
image_service=nova.image.glance.GlanceImageService
notification_topics=notifications
[api_database]
connection=mysql+pymysql://nova_api:openstack@10.10.150.191/nova_api
[barbican]
[cache]
[cells]
[cinder]
catalog_info=volumev2:cinderv2:publicURL
[conductor]
[cors]
[cors.subdomain]
[database]
connection=mysql+pymysql://nova:openstack@10.10.150.191/nova
[ephemeral_storage_encryption]
[glance]
api_servers=10.10.150.191:9292
[guestfs]
[hyperv]
[image_file_url]
[ironic]
[keymgr]
[keystone_authtoken]
[libvirt]
virt_type=qemu
inject_password=False
inject_key=False
inject_partition=-1
live_migration_uri=qemu+tcp://nova@%s/system
cpu_mode=host-model
vif_driver=nova.virt.libvirt.vif.LibvirtGenericVIFDriver
[matchmaker_redis]
[metrics]
[neutron]
url=http://10.10.150.191:9696
region_name=RegionOne
ovs_bridge=br-int
extension_sync_interval=600
auth_url=http://10.10.150.191:35357/v3
password=openstack
project_domain_name=Default
project_name=services
timeout=60
user_domain_name=Default
username=neutron
auth_plugin=v3password
[osapi_v21]
[oslo_concurrency]
lock_path=/var/lib/nova/tmp
[oslo_messaging_amqp]
[oslo_messaging_notifications]
driver = ceilometer.compute.nova_notifier
driver = messagingv2
driver = nova.openstack.common.notifier.rabbit_notifier
[oslo_messaging_rabbit]
amqp_durable_queues=False
kombu_reconnect_delay=1.0
rabbit_host=10.10.150.191
rabbit_port=5672
rabbit_hosts=10.10.150.191:5672
rabbit_use_ssl=False
rabbit_userid=guest
rabbit_password=guest
rabbit_virtual_host=/
rabbit_ha_queues=False
heartbeat_timeout_threshold=0
heartbeat_rate=2
[oslo_middleware]
[oslo_policy]
[rdp]
[serial_console]
[spice]
[ssl]
[trusted_computing]
[upgrade_levels]
[vmware]
[vnc]
enabled=True
keymap=en-us
vncserver_listen=0.0.0.0
vncserver_proxyclient_address=Mitaka-KVM1
novncproxy_base_url=http://10.10.150.191:6080/vnc_auto.html
[workarounds]
[xenserver]
edit retag flag offensive close merge delete

Comments

Perhaps the --limitoption helps? See https://docs.openstack.org/cli-refere....

By the way, I don't see nova.conf attached.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-08 15:30:38 -0500 )edit

From the referenced document:

API server limits result to <default_api_return_limit> rows if no limit provided. Option is configured in ceilometer.conf [api] group.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-08 18:18:43 -0500 )edit

I did provide limit ceilometer.conf file on both nodes and include controller and the compute node but I still don't see any compute.node.cpu, memory, and volume meters. default_api_return_limit = 10

mkhan gravatar imagemkhan ( 2017-06-09 09:21:16 -0500 )edit

Increase the limit. Also try ceilometer meter-show to confirm these metrics exist.

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-09 09:47:39 -0500 )edit

I don't see any of these metrics when I ran ceilometer meter-list, as I mentioned.

mkhan gravatar imagemkhan ( 2017-06-09 10:23:32 -0500 )edit