Ask Your Question
0

Nova can't authenticate to neutron

asked 2017-06-08 13:53:33 -0500

John Fleming gravatar image

updated 2017-06-13 18:27:28 -0500

UPDATE: 6 / 12 / 2017

All hope is lost.

As i stared deeply into the debugs i began to feel my grasp of reality slipping. I began to hear voices speaking in a language i didn't know but slowly began to understand. As I listened to the R'lyehian I began to understand what was happening. The ancient one was coming for me. But then my wife dropped all the openstack databases in mysql and then we made beer brats.

Gosh she is great.

UPDATE: 6 / 12 / 2017

UPDATE: 6 / 13 / 2017

recreated all databases.. same thing. :/

UPDATE: 6 / 13 / 2017

Hi all, this is my 3rd attempt openstack. I'm running 1 controller and 1 compute on Ubuntu 16.04.2 LTS. I've been walking through the install docs for ocata. I got horizon talking to just about everything. I can make networks, security groups, routers, volumes, add images, add flavors.

But when i try to lanuch an instance i get a

Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible. <class 'nova.exception.neutronadmincredentialconfigurationinvalid'=""> (HTTP 500) (Request-ID: req-5b8f0994-e276-43ef-b2c7-c4c42a9a05b2)</class>

192.168.1.50 is controller1 192.168.1.55 is compute1

This is with . admin-rc

nova --debug secgroup-list

fails as well.

The only thing i see in neutron-server.log that stands out is..


2017-06-08 10:53:59.314 5732 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 10:53:59] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 401 381 0.003359
2017-06-08 10:54:50.596 5727 INFO neutron.wsgi [req-dd6e7715-3d55-4894-bf3c-4663c63e31ab 9586b6005a1b455f85bd3fd2c14f15a0 c96b06f2721e48629a4627178bea77bd - - -] 192.168.1.50 - - [08/Jun/2017 10:54:50] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 200 3862 0.541847
2017-06-08 10:55:03.706 5721 INFO neutron.wsgi [req-f1c9f7e0-aa5b-4aa3-883e-2f1ef82dce23 9586b6005a1b455f85bd3fd2c14f15a0 c96b06f2721e48629a4627178bea77bd - - -] 192.168.1.50 - - [08/Jun/2017 10:55:03] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 200 3862 0.119310
2017-06-08 10:55:16.742 5722 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 10:55:16] "GET /v2.0/security-groups.json?fields=id&id=a8a09a32-c1a0-4e16-b7f6-c9b623a05355 HTTP/1.1" 401 381 0.452768
2017-06-08 10:55:16.749 5722 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 10:55:16] "GET /v2.0/security-groups.json?fields=id&id=a8a09a32-c1a0-4e16-b7f6-c9b623a05355 HTTP/1.1" 401 381 0.003270
2017-06-08 10:57:23.006 5729 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 10:57:23] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 401 381 0.435870
2017-06-08 10:57:23.013 5729 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 10:57:23] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 401 381 0.003278
2017-06-08 11:01:28.574 5732 INFO neutron.wsgi [-] 192.168.1.50 - - [08/Jun/2017 11:01:28] "GET /v2.0/security-groups.json?tenant_id=c96b06f2721e48629a4627178bea77bd HTTP/1.1" 401 381 0 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-06-14 18:50:28 -0500

John Fleming gravatar image

updated 2017-06-14 19:06:57 -0500

Well, i eyeballed my and yours and they looked to be the same.

I did happen to notice i had this in my [keystone_authtoken] section

service_token_roles_required = true

I'm sure you're thinking why on earth did you do that? I have no idea, i've been hacking on this for so long i have no idea which way is up. I have a completely new error now, but at least nova and neutron are talking ( nova secgroup-list works )! I removed it and everything started working .. well ... sort of at least.

Cthulhu be praised!

Oh and thank you for the reply!

edit flag offensive delete link more
0

answered 2017-06-14 03:40:29 -0500

updated 2017-06-14 03:42:57 -0500

Any errors inside the nova-api log? For me it looks like you have an error inside the nova.conf on your controller. This is the neutron section inside of mine

[neutron]
url = http://controller:9696
region_name = RegionOne
auth_url = http://controller:35357
auth_type = password
default_domain_name = default
project_domain_name = default
user_domain_name = default
username = neutron
password = niftypassword
project_name = service
service_metadata_proxy = True
metadata_proxy_shared_secret=niftysecret

I mean, your dashboard will setup networks with the neutronclient directly, so any errors inside the nova.conf will not affect this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-06-08 10:07:14 -0500

Seen: 537 times

Last updated: Jun 14 '17