unable to retrive project list in horizon

asked 2017-06-07 17:00:29 -0500

minimike gravatar image

updated 2017-06-07 18:38:28 -0500

Hi there

I'm developing an puppet-environment to install openstack on Ubuntu 16.04. But on Horizon I'm unable to retrive the project-list. Apache shows me someting like here

+----------------------------------+-----------+-----------------+--------------+---------+-----------+---------------------------------------------+
| ID                               | Region    | Service Name    | Service Type | Enabled | Interface | URL                                         |
+----------------------------------+-----------+-----------------+--------------+---------+-----------+---------------------------------------------+
| 05e44c4936f04fe08c2e0fe5663beabb | RegionOne | glance          | image        | True    | admin     | http://172.16.70.11:9292                    |
| 10b497fd914c46608abec9c130dff73a | RegionOne | Compute Service | compute      | True    | internal  | http://172.16.70.11:8774/v2.1/%(tenant_id)s |
| 317c27d13fdc436faceaba09675fe241 | RegionOne | glance          | image        | True    | internal  | http://172.16.70.11:9292                    |
| 3b6a0296b7e243cbae2a7b816741964c | RegionOne | glance          | image        | True    | public    | http://172.16.70.11:9292                    |
| 5d7e76060d9d4ab88f7b6f63cf940ba5 | RegionOne | placement       | placement    | True    | internal  | http://172.16.70.11:8778                    |
| 73179a1e0a7d4a7b984322269478fc04 | RegionOne | Compute Service | compute      | True    | public    | http://172.16.70.11:8774/v2.1/%(tenant_id)s |
| 7425d598886b4a73831f401116022bcc | RegionOne | designate       | dns          | True    | public    | http://172.16.70.11:9001                    |
| 7e531e7b944c4c6f8405bbd0ba124ced | RegionOne | placement       | placement    | True    | public    | http://172.16.70.11:8778                    |
| 812496ab690945ddb9c8b7da876ea5d6 | RegionOne | placement       | placement    | True    | admin     | http://172.16.70.11:8778                    |
| 95a2eb659b9046d0bc5da1b0dca6dcb6 | RegionOne | Compute Service | compute      | True    | admin     | http://172.16.70.11:8774/v2.1/%(tenant_id)s |
| a18bd2d1ccb84616a35094c324a3d188 | RegionOne | neutron         | network      | True    | admin     | http://172.16.70.11:9696                    |
| a4978c479c9f4aa59cd7a7b52e6d7a15 | RegionOne | designate       | dns          | True    | admin     | http://172.16.70.11:9001                    |
| a85655f6ba4f4b869d667e5a2a816752 | RegionOne | neutron         | network      | True    | internal  | http://172.16.70.11:9696                    |
| bb86d2e66ba0475787dd124ac3bbf001 | RegionOne | keystone        | identity     | True    | internal  | http://172.16.70.11:5000/v3/                |
| bc57d834c33b4f2fbbd360e48a8e4d40 | RegionOne | designate       | dns          | True    | internal  | http://172.16.70.11:9001                    |
| ca533fffe2f2496e8d5cca0cf0d10971 | RegionOne | neutron         | network      | True    | public    | http://172.16.70.11:9696                    |
| e1dfbd3f24f84a448b51b2473a72bddf | RegionOne | keystone        | identity     | True    | public    | http://172.16.70.11:5000/v3/                |
| ed1b7d9d53104a89b35ae22146aebee0 | RegionOne | keystone        | identity     | True    | admin     | http://172.16.70.11:35357/v3/               |
+----------------------------------+-----------+-----------------+--------------+---------+-----------+---------------------------------------------+


OPENSTACK_API_VERSIONS = {
"identity": 3,
"image": 2,
"volume": 2,
}

hmm endpoints and the local_settings.py looks OK. Any idea or hint what could going wrong here?

edit retag flag offensive close merge delete