Ask Your Question
0

Ocata, VNC shows Cirros instance stuck at "GRUB"

asked 2017-06-02 08:46:40 -0600

sidx64 gravatar image

updated 2017-06-02 09:09:27 -0600

rbowen gravatar image

Hello! I am working on building an openstack setup using the documentation at: https://docs.openstack.org/ocata/install-guide-rdo/. I am running two VMs on VMWare on a device with physical RAM 32GB and a Core i7 4810Q proccy. Both VMs are running on CentOS 7.3. Controller node has 8GB of RAM and the Compute Node has 16GB RAM

Currently facing an issue when building an instance of cirros. Issue: Cirros Instance stuck at "Booting from Harddisk GRUB" in the console VNC.

Can someone help me identify this issue?

Steps taken so far:

  1. I checked and ensured that nested virtualization is enabled on the VMWare Workstation [went to processor and enabled "Virtualize VT -x" option on both compute and controller node]

  2. I followed the documentation to the T (used provider network only option for neutron)

  3. The document asked me to check egrep -c '(vmx|svm)' /proc/cpuinfo and the result was "8". Hence did not set virt_type in /etc/nova/nova.conf

Some Command Outputs

Compute node CPUINFO

[root@okvm qemu]# egrep -c '(vmx|svm)' /proc/cpuinfo
8

hypervisor list

 [root@octl ~]# openstack hypervisor list
    +----+---------------------+-----------------+----------------+-------+
    | ID | Hypervisor Hostname | Hypervisor Type | Host IP        | State |
    +----+---------------------+-----------------+----------------+-------+
    |  1 | okvm                | QEMU            | 192.168.44.102 | up    |
    +----+---------------------+-----------------+----------------+-------+

Compute Services

 [root@octl ~]# openstack compute service list
    +----+------------------+------+----------+---------+-------+----------------------------+
    | ID | Binary           | Host | Zone     | Status  | State | Updated At                 |
    +----+------------------+------+----------+---------+-------+----------------------------+
    |  1 | nova-scheduler   | octl | internal | enabled | up    | 2017-06-02T12:46:12.000000 |
    |  2 | nova-consoleauth | octl | internal | enabled | up    | 2017-06-02T12:46:22.000000 |
    |  3 | nova-conductor   | octl | internal | enabled | up    | 2017-06-02T12:46:20.000000 |
    |  8 | nova-compute     | okvm | nova     | enabled | up    | 2017-06-02T12:46:14.000000 |
    +----+------------------+------+----------+---------+-------+----------------------------+

Nova Status

[root@octl ~]#  nova-status upgrade check
+---------------------------+
| Upgrade Check Results     |
+---------------------------+
| Check: Cells v2           |
| Result: Success           |
| Details: None             |
+---------------------------+
| Check: Placement API      |
| Result: Success           |
| Details: None             |
+---------------------------+
| Check: Resource Providers |
| Result: Success           |
| Details: None             |
+---------------------------+

Server says it is built successfully and is ACTIVE

[root@octl ~]# openstack server list
+--------------------------------------+-------------+--------+------------------------+------------+
| ID                                   | Name        | Status | Networks               | Image Name |
+--------------------------------------+-------------+--------+------------------------+------------+
| b3fd3f9d-e8f4-40ba-b433-457303ba768d | cirros-test | ACTIVE | provider=192.168.44.93 | cirros     |
+--------------------------------------+-------------+--------+------------------------+------------+

Instance Log

2017-06-02 13:05:38.688+0000: starting up libvirt version: 2.0.0, package: 10.el7_3.9 (CentOS BuildSystem <http://bugs.centos.org>, 2017-05-25-20:52:28, c1bm.rdu2.centos.org), qemu version: 2.6.0 (qemu-kvm-ev-2.6.0-28.el7_3.9.1), hostname: okvm
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -name guest=instance-00000004,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-1-instance-00000004/master-key.aes -machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off -cpu Haswell-noTSX,+vme,+ds,+ss,+ht,+vmx,+osxsave,+f16c,+rdrand,+hypervisor,+arat,+tsc_adjust,+xsaveopt,+pdpe1gb,+abm -m 64 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid ad2f8a18-7e91-4016-b80d-2539b2a43877 -smbios 'type=1,manufacturer=RDO,product=OpenStack Compute,version=15.0.3-2.el7,serial=ac0bec73-3ef5-4a89-a439-690339e1121d,uuid=ad2f8a18-7e91-4016-b80d-2539b2a43877,family=Virtual Machine' -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-1-instance-00000004/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id ...
(more)
edit retag flag offensive close merge delete

Comments

Try playing with the cpu_mode and cpu_model parameters; see https://docs.openstack.org/ocata/conf....

Bernd Bausch gravatar imageBernd Bausch ( 2017-06-02 09:38:48 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-06-07 17:27:02 -0600

updated 2017-08-30 10:44:06 -0600


Update with a quick fix:

On the compute node(s) in the [libvirt] section of /etc/nova/nova.conf set hw_machine_type as follows:

hw_machine_type = x86_64=pc-i440fx-rhel7.2.0


I had the same problem when I tried to upgrade two compute nodes from CentOS 7.2 to 7.3. You can find more details about the issue, if you google "Openstack doesn't work on CentOS 7.3 update" (question #407577).

Try CentOS 7.2 on a new compute node or downgrade kernel on your existing compute node from 3.10.0-514 to 3.10.0-327.

edit flag offensive delete link more
0

answered 2017-06-03 07:25:11 -0600

amrith gravatar image

I believe you are facing the same issue as the one described (by me) in the bug [1]. To tell for sure, here are a couple of things to do. Let me emphasize that this is a hunch, not a conclusive diagnosis.

On your VMWare VM, verify the version of libvirtd. If you are running 2.5.0 (which is what I ended up with in Ubuntu when the Ubuntu Cloud Archive was enabled), I had the exact same issue. If I use libvirtd of 1.3.1, things work fine.

My environment is similar to yours but substitute Ubuntu for Centos.

  • Windows 10 or Mac running VMWare VM
  • VMWare VM running Ubuntu and OpenStack as a compute node.
  • Nested Hypervisor VM for Nova (Cirros or full Ubuntu)
  • VT-X enabled in VMWare

I ended up with the exact same thing, the Nova instance would get stuck on the GRUB line on the console.

Not sure how you'd go about unraveling this in your environment but at least it may help you identify whether you are running into the same problem.

If you want more information, ping me on #openstack-dev, or #openstack-trove.

[1] https://bugs.launchpad.net/devstack/+...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-06-02 08:46:40 -0600

Seen: 535 times

Last updated: Aug 30