Ask Your Question
0

devstack: fails HTTPMultipleChoices (HTTP 300) Requested version of OpenStack Images API is not available

asked 2017-06-02 14:35:30 -0500

dlr2dlr2 gravatar image

OK, I think that everything is set correctly but when I try to create a stack I get:

ERROR: Property error: : resources.dcae_c_vm.properties.image: : HTTPMultipleChoices (HTTP 300) Requested version of OpenStack Images API is not available.

env is (... are redacted text):

OS_AUTH_URL=http://10.0.0.43/identity/v3
OS_IDENTITY_API_VERSION=3
OS_IMAGE_API_VERSION=2
OS_INTERFACE=public
OS_PASSWORD=...
OS_PROJECT_DOMAIN_NAME=Default
OS_PROJECT_NAME=...
OS_REGION_NAME=RegionOne
OS_USER_DOMAIN_NAME=Default
OS_USERNAME=demo

glance and openstack interfaces work fine, for example:

stack@opcoast-ryzen ~/onap $ glance image-list
+--------------------------------------+--------------------------+
| ID                                   | Name                     |
+--------------------------------------+--------------------------+
| 707959ad-9c72-41ca-9af8-1d1e84d393af | cirros-0.3.5-x86_64-disk |
| c8380353-9554-48f4-9383-4a13ba3e9827 | ubuntu14                 |
| 699a5810-8da2-4aac-83e2-f93d47eebc2a | ubuntu16                 |
+--------------------------------------+--------------------------+

But I get that HTTP 300 error when I try to create a stack via yaml. I also tried setting the HEAT_API_VERSION env to 1 or 2 but that doesn't help. Are there heat settings that I am missing?

Here is a openstacj stackcreate with debug: https://docs.google.com/document/d/1c4WogZodTCe6DcXWzXput3VOBc8MuWhFki6pX9HNrtw (https://docs.google.com/document/d/1c...)

edit retag flag offensive close merge delete

Comments

This is awaiting moderation after 15 hours? Is this normal (its my first question here).

dlr2dlr2 gravatar imagedlr2dlr2 ( 2017-06-02 09:37:30 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-05 08:42:34 -0500

zaneb gravatar image

Heat used to use the Glance v1 API up until this patch merged in Ocata. So if you have an older version of Heat that doesn't include that patch, and you have only deployed the Glance v2 API not v1, then you will get this error.

edit flag offensive delete link more

Comments

Thanks so much, the patch fixed this!

dlr2dlr2 gravatar imagedlr2dlr2 ( 2017-06-05 11:54:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-06-01 15:28:40 -0500

Seen: 345 times

Last updated: Jun 05 '17