Ask Your Question
0

Packstack Installation on CentOS - Problem with NTP Server

asked 2017-05-31 05:39:00 -0500

Rez7 gravatar image

Hello all,

Three months ago i managed to install OpenStack using Packstack on three nodes. Yesterday i did the very same procedure to install it on another server as a test bed. Installation ended and i could access Horizon, however there wasn't a message to say: * Installation completed successfully *** and i ran into an error as follow:

ERROR : Error appeared during Puppet run: 172.17.101.40_controller.pp Error: /usr/sbin/ntpdate pool.ntp.org/ returned 1 instead of one of [0]

I searched here and there, and they mentioned that there is a bug regarding ntp server resiliency and there was a workaround, to mention more than one ntp server in your "answer scripted file", something like this:

Workaround: Specifying multiple separate pools helps in mitigating the issue, for example:

CONFIG_NTP_SERVERS=0.pool.ntp.org,1.p...

I followed it and again the same error came up:

ERROR : Error appeared during Puppet run: 172.17.101.40_controller.pp Error: /usr/sbin/ntpdate 0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org returned 1 instead of one of [0]

Any suggetion to solve this, please? Rez

edit retag flag offensive close merge delete

Comments

Did you check if the NTP servers are reachable? Just use the same command /usr/sbin/ntpdate 0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-31 05:52:06 -0500 )edit

They all seem reachable using "ping" command.

Rez7 gravatar imageRez7 ( 2017-05-31 06:30:40 -0500 )edit

Puppet doesn't ping, but uses ntpdate. Apart from connectivity, there could be other problems, e.g. permissions (ntpdate requires superuser privileges afaik), or perhaps ntpdate is not installed.

Run packstack -d, then check the log files for the output of the ntpdate command.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-31 19:32:23 -0500 )edit

I followed your recommendations and i did some troubleshooting ...it turned out that UDP port 123 was blocked by edge firewall. Thank you.

Rez7 gravatar imageRez7 ( 2017-06-03 08:54:51 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-09-26 07:49:27 -0500

amit_bahuguna gravatar image

updated 2017-09-26 07:49:58 -0500

I had same problem. make sure ntp is installed and provide correct NTP server in ntp.conf and answer.txt. Now ntpdate NTP-server-IP is working for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-31 05:39:00 -0500

Seen: 1,078 times

Last updated: Sep 26 '17